Bug 205087 - X.org VIA driver broken -- newer version available
X.org VIA driver broken -- newer version available
Status: CLOSED DUPLICATE of bug 338361
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-via (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 21:01 EDT by W. Michael Petullo
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 11:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2006-09-03 21:01:25 EDT
Description of problem:
The VIA driver included in Rawhide is out of date and broken when used with a
VIA Epia ME6000 motherboard.

Version-Release number of selected component (if applicable):
xorg-x11-drv-via-0.2.1-4.1

How reproducible:
Every time

Steps to Reproduce:
Configure X to use the VIA driver.  Enable hardware acceleration.
  
Actual results:
Screen goes blank when X initializes.

Expected results:
X should display.

Additional info:
This is fixed with version 0.2.6 of the VIA driver, available at
http://unichrome.sourceforge.net/.  A (fixed) bug report was made at:

http://sourceforge.net/tracker/index.php?func=detail&aid=1349309&group_id=102048&atid=630967
Comment 1 Warren Togami 2006-09-20 12:17:43 EDT
Unichrome is a fork of the via driver.  It reportedly does not support
everything the via driver does, so it cannot replace and remove via.

You may want to package this for Extras in order to provide a convenient option
for yourself and users, but it would need to be done in some way that doesn't
conflict with via... which may not be easy given that they overlap in hardware
support.
Comment 4 Xavier Bachelot 2007-06-07 09:01:57 EDT
There is yet another fork of the xorg via driver at openchrome.org. openchrome
is an evolution of the code in the official xorg driver and hence supports
everything the xorg driver supports, and add supports for more chipsets. Work is
currently being done in openchrome to rename the DDX and the associated libs in
order not to conflicts with files from the official xorg driver. I'm maintaining
a replacement version of the driver that is currently shipped with fedora for a
long time now. I'm willing to submit a xorg-x11-drv-openchrome package once
openchrome officially release a tarball (in the coming weeks). What is not clear
to me yet is how the via.xinf file interacts with the choice of the good driver
for the hardware, but this can probably be addressed later. I'll talk with the
maintainer of the unichrome.sf.net driver about doing the same sort of renaming
and possibly package it too (altough I'm not using it because of the lack of
support for hardware mpeg acceleration).
I also have packages for patched mesa and xorg-server for via based graphic
chipsets but this is a slightly different matter not belonging to this bug.
Comment 5 Xavier Bachelot 2007-10-18 13:33:42 EDT
openchrome driver has been submitted :
https://bugzilla.redhat.com/show_bug.cgi?id=338361

I also have a non-conflicting package for unichrome driver (with both
xorg-x11-drv-via and xorg-x11-drv-openchrome), but I'm not ready to submit it as
I don't really use it. Lemme know if anyone is interested, I'll happily give a
link to the spec and srpm.
Comment 6 Adam Jackson 2007-10-22 11:42:44 EDT
openchrome ftw

*** This bug has been marked as a duplicate of 338361 ***

Note You need to log in before you can comment on or make changes to this bug.