Bug 205092 - HP scanjet 5300c is not detected by scanimage -L
HP scanjet 5300c is not detected by scanimage -L
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
5
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On: 200122
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 22:19 EDT by Francis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 09:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francis 2006-09-03 22:19:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
I have a USB HP scanjet 5300c scanner.  
When I type sane-find-scanner, it says it finds my usb scanner. But when I try to use scanimage -L or Xsane, it says no scanners found. 


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Type sane-find-scanner, says it finds it
2. Type scanimage -L, says no scanners found
3.

Actual Results:
Nothing, can't scan at all.

Expected Results:
I should have been able to scan. 

Additional info:
I get this problem with Fedora Core 5 and also from the Fedora Core 6 Test 2 Live CD (although that's for the i386 platform). But my scanner is detected and works fine under windows or ubuntu 6.
Comment 1 Kevin R. Page 2006-09-07 09:06:17 EDT
You're likely experiencing two problems: one with sane-backends (which I'll
describe below), and one with USB in the kernel.

For the kernel issue, please see bug 200122. If, when you try FC6t2, if you
aren't using a USB2 hub (i.e. the scanner is controller by uhci_hcd, not
ehci_hcd) and you don't see an error in /var/log/messages, please add details to
bug 200122 - it may be that the problem is fixed in a later kernel.

When I've overcome bug 200122 by using a USB2 hub, scanimage -L _does_ find the
5370C - this is with sane-backends-1.0.17-5 (the current FC5 update).

However, if I try to scan using scanimage or xsane, the scan head briefly moves
- but then eventually xsane or scanimage will time out with an I/O error. no
scan takes place.

Worse still, the scanner in now in a state where it can't be detected or used.
The best way I've found to fix this is to: power the scanner down; reset the USB
controller by modprobing out and in ehci_hcd (or uhci_hcd were it working); then
powering the scanner up again.

N.B. For bug hunting purposes be very aware that once you've tried to use the
scanner it will be stuck in this (differently broken) state until you perform
the above actions - i.e. you have to reset it before trying something else.
Unplugging and replugging the scanner's USB cable doesn't work - it results in
another (different again) USB error message.

The good news, however, is that sane-backends-1.0.18 fixes this - I rebuilt the
FC6 sane-backends-1.0.18 source RPM on an FC5 machine, and the scanner then works.

Therefore could an update to sane-backends be pushed out for FC5 too, please.

(Bug reporter or owner: please could you change the title and details of this
bug to reflect the errors with sane-backends-1.0.17-5.FC5 - to keep the USB part
of the problem in bug 200122. I guess this bug is now an update request. Thanks.)
Comment 2 Nils Philippsen 2006-09-08 05:44:11 EDT
sane-backends-1.0.18-2.fc5 sould hit updates-testing soon, please test
Comment 3 Francis 2006-09-08 19:53:33 EDT
(In reply to comment #2)
> sane-backends-1.0.18-2.fc5 sould hit updates-testing soon, please test

Will there be a link where I can check to see if it's available or can I just
use the Software Updater in FC5. 
Comment 4 Nils Philippsen 2006-09-11 05:57:04 EDT
The packages are still in updates-testing, so you can (as root) either do:

yum --enablerepo=updates-testing update sane-backends\*

or download the packages manually at
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/5/i386/
and install them with "yum localinstall sane-backends*.rpm".
Comment 5 Francis 2006-09-11 07:05:16 EDT
I installed the test update for the sane-backends but unfortunately it did not
fix the problem.  I still get "No scanners were identified" when running
scanimage -L.
sane-find-scanner still works. 

By the way, my kernel version is 2.6.17-1.2174_FC5. If you need more info about
my computer, please let me know. 
Comment 6 Nils Philippsen 2006-09-11 09:10:45 EDT
As far as I can tell, with the update to sane-backends-1.0.18, the user level
part of the problem should be solved (Kevin?). Francis, in that case, I'll leave
the bug in MODIFIED until there is a chance for you to test this with a kernel
containing a fix for bug #200122 (which this bug is depending upon now).
Comment 7 Kevin R. Page 2006-09-11 19:41:13 EDT
The good news: The package in updates-testing Works For Me.
Francis: if you can get hold of a USB2 hub that may allow you to work around bug
200122.

The bad news: bug 206094. It has the same smell to it.
Comment 8 Francis 2006-09-17 05:55:55 EDT
Just to let you know, I updated my kernel to 2.6.17-1.2187_FC5 to see if it
would fix the bug, but it's still no good. 

Oh well, don't worry about this bug too much, it's not a big deal for me. I'm
sure you guys have other more important bugs to fix. I have my computer dual
booting anyway plus I don't use the scanner that much. My computer is old, but
heck FC5 runs so smooth on it :)  Planning to get a new computer also. 

Maybe this bug will be fixed when the final release of FC6 comes out.  Anyways,
thanks for your help gentlemen. I really appreciate it. 
Comment 9 Nils Philippsen 2007-11-07 09:50:35 EST
According to comment #7, I'll close this bug as the user space components seem
to be fixed (and FC5 is dead anyway).

Note You need to log in before you can comment on or make changes to this bug.