Bug 205095 - monodoc-1.1.17-1.fc5.x86_64 installs monodoc.dll in wrong location
monodoc-1.1.17-1.fc5.x86_64 installs monodoc.dll in wrong location
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: monodoc (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 23:50 EDT by Dean Brettle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 14:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Brettle 2006-09-03 23:50:43 EDT
Description of problem:

monodoc-1.1.17-1.fc5.x86_64 installs monodoc.dll under /usr/lib64/mono instead
of /usr/lib/mono.  As a a result monodevelop can't find it and can't start.

Version-Release number of selected component (if applicable):

monodoc-1.1.17-1.fc5.x86_64
monodevelop-0.11-16.fc5

How reproducible:

Everytime

Steps to Reproduce:
1. Install monodoc-1.1.17-1.fc5.x86_64
2. Start monodevelop
  
Actual results:

Error saying it can't find monodoc assembly.

Expected results:

Monodevelop should start.

Additional info:

I worked around the problem by reverting to monodoc-1.1.16-1.fc5.x86_64.
Comment 1 Paul F. Johnson 2006-09-04 11:57:27 EDT
Actually, this isn't a bug - monodoc on x86_64 should be putting things in
/usr/lib64 - the problem is that monodevelop is looking in the wrong place.
gecko-sharp was holding a rebuild of monodevelop up (I was unaware it was
broken), but that has been fixed.

Assuming gecko-sharp hits the next push, I can get a new monodevelop out tomorrow.
Comment 2 Dean Brettle 2006-09-04 13:52:25 EDT
It sounds like the relocation (from lib to lib64) is an incompatible change that
requires all apps that use monodoc.dll to be rebuilt, including those that
aren't included in Extras.  IMO, such a change isn't appropriate for an update
to a stable distribution.  Perhaps the dll should be installed in both locations
until at least FC6.  Ideally the FC6 would continue to support both locations
but the release notes would officially deprecate it and indicate that only lib64
would work in FC7.

Just my $.02.

Comment 3 Paul F. Johnson 2006-09-04 14:23:52 EDT
There are no apps in core that require monodoc. As far as I am aware (and I
review a lot of the mono apps going into extras), there is nothing in extras
other than monodevelop which uses monodoc.

The change will be fully into FC6 (it's already in rawhide and has been for
quite a while now) and should work in FC5 (it certainly has on my test rigs)

Note You need to log in before you can comment on or make changes to this bug.