Bug 205105 - Enhancement requests: make utility more configurable, stop warnings and make backup of config files.
Enhancement requests: make utility more configurable, stop warnings and make ...
Product: Fedora
Classification: Fedora
Component: system-config-netboot (Show other bugs)
noarch Linux
medium Severity low
: ---
: ---
Assigned To: Radek Brich
Depends On:
  Show dependency treegraph
Reported: 2006-09-04 03:28 EDT by Colin Coe
Modified: 2008-05-06 20:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 20:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Colin Coe 2006-09-04 03:28:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 1.0.3705)

Description of problem:
1) It would be nice if the path system-config-netboot uses could be configured in, for example, /etc/sysconfig/netboot: DEFAULT=/tftpboot/linux-install rather than having to hack the Python source (to remove '/linux-install')

2) System-config-netboot displays warnings on startup about my config files in /tftpboot/pxelinux.cfg because they are named 'incorrectly'.  i.e.
lrwxrwxrwx  1 root  root   14 Sep  4 15:26 0AF022 -> el3u7_csl_ldap
lrwxrwxrwx  1 root  root   14 Sep  4 15:26 0AF029 -> el3u7_lws_ldap

3) Lastly, it would be really nice if system-config-netboot backed up files (such as 0AF029) before replacing them.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
N/A: Enhancement request

Actual Results:

Expected Results:

Additional info:
Comment 1 Matthew Miller 2007-04-06 12:12:57 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Fabio Olive Leite 2007-11-12 15:40:56 EST
Reassigning to component owner.
Comment 3 Colin Coe 2007-11-12 17:02:14 EST
system-config-netboot is missing from Fedora 8 and Fedora 7 uses exactly the 
same version of system-config-netboot as FC6.


Comment 4 Radek Brich 2007-11-13 05:17:27 EST
There should be s-c-netboot 0.1.42 in F7 and F8, I updated them recently. I can
even see it on mirrors, e.g. system-config-netboot-0.1.42-1.fc8.noarch.rpm
Comment 5 Radek Brich 2007-11-13 12:22:44 EST
ad 1)
That seems reasonable though you can configure it just fine now, no big hacking.
Look for PXEBOOTDIR in netboot_util.py. It's used everywhere except one place in
pxeos.py, which can be fixed by this patch (that's a bug):
<         return "/tftpboot/linux-install/" + self.getNameDir()
>         return PXEBOOTDIR + self.getNameDir()

Anyway, I'll add support for preferences file with next release.

ad 2)
I don't really understand what is the problem. I tried to make those symlinks
but system-config-netboot didn't complain about anything. It worked even with
multiple symlinks pointing to one config.

ad 3)
Again, I don't understand why exactly you need those backups. S-c-nb should not
overwrite any options except those which can be defined in GUI (or on command
line, depending on tool used).

Thanks for the bug report and try to be more specific, please. Some
examples/error messages would certainly help.

(moving this to Fdevel as FC6 will be EOL'ed soon)
Comment 6 Bug Zapper 2008-04-03 14:07:24 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Bug Zapper 2008-05-06 20:48:32 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.