Bug 2051108 - yum cannot update ipa-server-dns
Summary: yum cannot update ipa-server-dns
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: CentOS Stream
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Florence Blanc-Renaud
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-06 11:16 UTC by Yaniv Cohen
Modified: 2022-02-09 14:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-09 11:19:26 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker FREEIPA-7804 0 None None None 2022-02-06 11:18:56 UTC
Red Hat Issue Tracker RHELPLAN-111241 0 None None None 2022-02-06 11:19:00 UTC

Description Yaniv Cohen 2022-02-06 11:16:20 UTC
Description of problem:

yum update fails to update ipa-server-dns

Version-Release number of selected component (if applicable):
ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64                                                              

How reproducible:
yum update 

Steps to Reproduce:
1. have fully updated centos8-stream
2. run dnf/yum update
3.

Actual results:
 Problem 1: package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-6.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-3.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-4.el8_4.x86_64
  - cannot install the best update candidate for package bind-libs-lite-32:9.11.26-6.el8.x86_64
  - cannot install the best update candidate for package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64
 Problem 2: problem with installed package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64
  - package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-6.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-3.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-4.el8_4.x86_64
  - package bind-32:9.11.36-2.el8.x86_64 requires libdns.so.1115()(64bit), but none of the providers can be installed
  - package bind-32:9.11.36-2.el8.x86_64 requires bind-libs-lite(x86-64) = 32:9.11.36-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package bind-32:9.11.26-6.el8.x86_64
 Problem 3: package ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch requires bind-dyndb-ldap >= 11.2-2, but none of the providers can be installed
  - package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - package bind-dyndb-ldap-11.6-2.module_el8.4.0+639+a88aab78.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-6.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-3.el8.x86_64
  - cannot install both bind-libs-lite-32:9.11.36-2.el8.x86_64 and bind-libs-lite-32:9.11.26-4.el8_4.x86_64
  - package bind-libs-32:9.11.36-2.el8.x86_64 requires libdns.so.1115()(64bit), but none of the providers can be installed
  - package bind-libs-32:9.11.36-2.el8.x86_64 requires bind-libs-lite(x86-64) = 32:9.11.36-2.el8, but none of the providers can be installed
  - cannot install the best update candidate for package ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
  - cannot install the best update candidate for package bind-libs-32:9.11.26-6.el8.x86_64
 Problem 4: problem with installed package ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
  - package ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch requires bind-dyndb-ldap >= 11.2-2, but none of the providers can be installed
  - package bind-dyndb-ldap-11.6-2.module_el8.5.0+750+c59b186b.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - package bind-dyndb-ldap-11.6-2.module_el8.4.0+639+a88aab78.x86_64 requires libdns.so.1112()(64bit), but none of the providers can be installed
  - package bind-libs-lite-32:9.11.26-6.el8.x86_64 requires bind-license = 32:9.11.26-6.el8, but none of the providers can be installed
  - package bind-libs-lite-32:9.11.26-3.el8.x86_64 requires bind-license = 32:9.11.26-3.el8, but none of the providers can be installed
  - package bind-libs-lite-32:9.11.26-4.el8_4.x86_64 requires bind-license = 32:9.11.26-4.el8_4, but none of the providers can be installed
  - cannot install both bind-license-32:9.11.36-2.el8.noarch and bind-license-32:9.11.26-6.el8.noarch
  - cannot install both bind-license-32:9.11.36-2.el8.noarch and bind-license-32:9.11.26-3.el8.noarch
  - cannot install both bind-license-32:9.11.36-2.el8.noarch and bind-license-32:9.11.26-4.el8_4.noarch
  - cannot install the best update candidate for package bind-license-32:9.11.26-6.el8.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Expected results:
successful update


Additional info:

Operating System: CentOS Stream 8
Kernel: Linux 4.18.0-358.el8.x86_64

python3-ipaserver-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
ipa-client-common-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
sssd-ipa-2.6.1-2.el8.x86_64
ipa-common-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
ipa-server-4.9.8-2.module_el8.6.0+1053+0ac05726.x86_64
ipa-server-dns-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
python3-libipa_hbac-2.6.1-2.el8.x86_64
python3-ipaclient-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
libipa_hbac-2.6.1-2.el8.x86_64
ipa-selinux-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
ipa-client-4.9.8-2.module_el8.6.0+1053+0ac05726.x86_64
python3-iniparse-0.4-31.el8.noarch
centos-logos-ipa-85.8-2.el8.noarch
ipa-healthcheck-core-0.7-7.module_el8.6.0+1053+0ac05726.noarch
ipa-server-common-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
python3-ipalib-4.9.8-2.module_el8.6.0+1053+0ac05726.noarch
ipa-healthcheck-0.7-7.module_el8.6.0+1053+0ac05726.noarch

Comment 4 Johnny Hughes 2022-02-09 11:19:26 UTC
This issue has been corrected with the release of https://koji.mbox.centos.org/koji/buildinfo?buildID=21079

Comment 5 Yaniv Cohen 2022-02-09 11:32:33 UTC
I can confirm bug is fixed.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.