Bug 205112 - Broken build - missing libgs.so.7
Broken build - missing libgs.so.7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gsview (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-04 05:12 EDT by Jan Kratochvil
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 09:58:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2006-09-04 05:12:23 EDT
Description of problem:
The build of gsview is broken as it requires libgs.so.7 but libgs.so.8 is only
available.

Version-Release number of selected component (if applicable):
gsview-4.7-6.fc5.i386
ghostscript-8.15.2-8.1.i386

How reproducible:
Always.

Steps to Reproduce:
1. Start gsview.
  
Actual results:
It will not start.

Expected results:
It would start.

Additional info:
GSview 4.7 2005-03-25
play_sound: not implemented
debug=0
Failed to load libgs.so.7: libgs.so.7: cannot open shared object file: No such
file or directory
Can't load Ghostscript DLL
Comment 1 Jan Kratochvil 2006-09-04 06:29:41 EDT
And BTW I forgot I hope it is clear "gsview" should "Requires: libgs.so.8".
Maybe better: "Requires: ghostscript >= 8.0.0" (if it is true).
Comment 2 Rex Dieter 2006-09-04 09:52:43 EDT
Hrm.  gsview was *supposed* to be removed from Extras months ago (licensing
issues). ???  I'll have to find out how/why it snuck back in.
Comment 3 Jan Kratochvil 2006-09-04 09:58:17 EDT
Oh, OK, both gv(1) and evince(1) are also usable. I will forget about gsview(1).
Sorry, it is just left installed, yum(8) did not complain / delete it.
I was just still used to it.

Note You need to log in before you can comment on or make changes to this bug.