Bug 205127 - Review Request: ekg - A client compatible with Gadu-Gadu
Review Request: ekg - A client compatible with Gadu-Gadu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Package Reviews List
:
Depends On:
Blocks: FE-ACCEPT 200436 205136
  Show dependency treegraph
 
Reported: 2006-09-04 08:46 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2009-09-21 16:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 09:32:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2006-09-04 08:46:06 EDT
Spec URL: http://rpm.greysector.net/extras/ekg.spec
SRPM URL: http://rpm.greysector.net/extras/ekg-1.7-0.1.rc2.src.rpm
Description:
EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
client for UNIX systems. Gadu-Gadu is an instant messaging program,
very popular in Poland.

NOTE: this package contains the libgadu library, which can be used by other Instant Messaging software.
Comment 1 Michał Bentkowski 2006-09-04 13:15:03 EDT
Official review:

MUST items:

 * rpmlint output:
W: libgadu no-documentation
 * package is named good.
 * spec file is named good.
 * package almost meets Packaging Guidelines (it'll be defined later)
 * License field matches actual license
 * license is NOT included in %doc in libgadu
 * spec file is legible
 * md5sums are matching (b4ea482130e163af1456699e2e6983d9)
 * package successfully builds on x86_64
 * build dependencies are properly listed in BuildRequires
 * no locales
 * package contains shared library files and package calls ldconfig
in %post and %postun
 * package owns its directories
 * no duplicates in %files
 * correct %defattr lines
 * proper %clean section
 * no gui

THINGS you have to do:

 * add %{?dist} tag to Release
 * add license file to libgadu package (COPYING is in lib directory)
 * remove python BR, because python-devel will add it

If you fix what I mentioned above, I'll approve it.
Comment 2 Dominik 'Rathann' Mierzejewski 2006-09-06 13:45:41 EDT
http://rpm.greysector.net/extras/ekg.spec
http://rpm.greysector.net/extras/ekg-1.7-0.2.rc2.src.rpm

- add dist tag
- add license files to libgadu and ekg
- remove reduntant python BR
- fix parallel make build
Comment 3 Michał Bentkowski 2006-09-06 16:56:39 EDT
Approved.
Comment 4 Dominik 'Rathann' Mierzejewski 2006-09-07 09:32:33 EDT
Imported and built for devel. FC-5 branch requested.

Note You need to log in before you can comment on or make changes to this bug.