Bug 2051367 (CVE-2021-45429) - CVE-2021-45429 yara: A Buffer Overflow vulnerablity exists in YARA
Summary: CVE-2021-45429 yara: A Buffer Overflow vulnerablity exists in YARA
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-45429
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2051369 2051368
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-07 06:23 UTC by Sandipan Roy
Modified: 2022-02-07 07:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-07 07:13:37 UTC


Attachments (Terms of Use)

Description Sandipan Roy 2022-02-07 06:23:38 UTC
A Buffer Overflow vulnerablity exists in VirusTotal YARA git commit: 605b2edf07ed8eb9a2c61ba22eb2e7c362f47ba7 via yr_set_configuration in yara/libyara/libyara.c, which could cause a Denial of Service.

https://github.com/VirusTotal/yara/issues/1616

Comment 1 Sandipan Roy 2022-02-07 06:24:03 UTC
Created yara tracking bugs for this issue:

Affects: epel-all [bug 2051369]
Affects: fedora-all [bug 2051368]

Comment 2 Product Security DevOps Team 2022-02-07 07:13:35 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.