Bug 205144 - Hibernate fails on Thinkpad T60
Summary: Hibernate fails on Thinkpad T60
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-04 19:34 UTC by Han-Wen Nienhuys
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 2.6.20-1.2925.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 21:41:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg output (53.49 KB, text/plain)
2006-09-04 19:34 UTC, Han-Wen Nienhuys
no flags Details
output of lspci -n (633 bytes, text/plain)
2006-11-29 22:51 UTC, Fabrice Bellet
no flags Details
output of lspci -v (8.35 KB, text/plain)
2006-11-29 22:52 UTC, Fabrice Bellet
no flags Details

Description Han-Wen Nienhuys 2006-09-04 19:34:25 UTC
Description of problem:

pm-hibernate ends in endless messages

  " end_request: I/O error in device sda sector 20839329

(message is approximate - they don't end up in the syslog).

Machine is a lenove TP T60, dmesg output attached. 

This is with all kernels after FC6t2 (haven't tested earlier versions)
 
kernel-2.6.17-1.2586.fc6
kernel-2.6.17-1.2608.fc6

Comment 1 Han-Wen Nienhuys 2006-09-04 19:34:26 UTC
Created attachment 135510 [details]
Dmesg output

Comment 2 David Lawrence 2006-09-05 15:28:30 UTC
Reassigning to correct owner, kernel-maint.

Comment 3 Fabrice Bellet 2006-11-29 22:13:46 UTC
This bug is related to ahci. Setting SATA mode to "compatibility" in BIOS, and
using ata_piix instead of ahci makes suspend-to-disk work for me (Thinkpad T60p,
kernel-2.6.18-1.2849.fc6).

Comment 4 Konrad Rzeszutek 2006-11-29 22:32:11 UTC
Fabrice,

What is the Vendor:Product ID on your storage controller? If you could paste in
the output of:
lspci -v
lspci -n

it would be appreciated.

Comment 5 Fabrice Bellet 2006-11-29 22:51:21 UTC
Created attachment 142450 [details]
output of lspci -n

Comment 6 Fabrice Bellet 2006-11-29 22:52:01 UTC
Created attachment 142451 [details]
output of lspci -v

Comment 7 Han-Wen Nienhuys 2007-02-16 11:22:15 UTC
(In reply to comment #3)
> This bug is related to ahci. Setting SATA mode to "compatibility" in BIOS, and
> using ata_piix instead of ahci makes suspend-to-disk work for me (Thinkpad T60p,
> kernel-2.6.18-1.2849.fc6).

I tried this once, but got kernel panics during the boot sequence.

Comment 8 Stefan Becker 2007-02-16 11:26:57 UTC
(In reply to comment #7)

I verified that the appraoch in comment #3 works.

But *before* switching the BIOS setting you need to generate a new initrd which
includes also the ata_piix module. By default it will only include the ahci
module as that is the active driver module for the root partition when the
original initrd has been created.


Comment 9 Han-Wen Nienhuys 2007-02-16 11:32:40 UTC
where can I find out how to do that?


Comment 10 Stefan Becker 2007-02-16 11:56:45 UTC
I'm not sure if it's documented somewhere but here is what I did:

Create the file /etc/sysconfig/mkinitrd and add the line:

MODULES="ahci ata_piix"

Now every time a new kernel gets installed mkinitrd will always add both modules
to the initrd. Now run the following command to update the initrd of the
currently running kernel:

# new-kernel-pkg --mkinitrd --update $(uname -r)


Comment 11 Han-Wen Nienhuys 2007-02-16 14:08:49 UTC
(In reply to comment #10)
> I'm not sure if it's documented somewhere but here is what I did:

thanks.
Works for me now.
 

Comment 12 Fabrice Bellet 2007-02-16 14:23:14 UTC
IRC, the problem with the SATA "compatibility" mode is that DMA is off on the
dvd drive.

Comment 13 Fabrice Bellet 2007-03-13 21:01:54 UTC
Hibernate with AHCI now works for me in kernel-2.6.20-1.2925.fc6

Comment 14 Stefan Becker 2007-03-14 06:53:34 UTC
Confirmed. Hibernate works with AHCI on kernel-2.6.20-1.2925.fc6 from FC6
updates-testing.


Note You need to log in before you can comment on or make changes to this bug.