Bug 205168 - FC5 detected Creative Labs SB Live! EMU10k1, but no sound
FC5 detected Creative Labs SB Live! EMU10k1, but no sound
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: redhat-config-soundcard (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 02:20 EDT by Benjamin W. Slivka
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 10:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The sound configuration log file (16.88 KB, text/plain)
2006-09-05 02:20 EDT, Benjamin W. Slivka
no flags Details
scsconfig.log (36.85 KB, text/plain)
2006-09-24 12:27 EDT, Dave Russell
no flags Details
scsrun.log (683 bytes, text/plain)
2006-09-24 12:28 EDT, Dave Russell
no flags Details

  None (edit)
Description Benjamin W. Slivka 2006-09-05 02:20:46 EDT
Description of problem:

I installed FC5 off DVD included in Red Hat Fedora 5 Unleashed (by Sams).
Everything went smoothly, but no sound.  I know it was working, because before
the FC5 install this machine was running Windows XP and sound worked fine.

Audio Devices detects:
Vendor: Creative
Model:  Labs SB Live! EMU10k1
Module: snd-emu10k1

I tried all of the different "Default PCM device" choices, but no sound when I
push the play button.  

Version-Release number of selected component (if applicable):


How reproducible:
{see above}

Steps to Reproduce:
1. {see above}
2.
3.
  
Actual results:
No sound.

Expected results:
Sound!

Additional info:
This is a Gateway Pentium III 933MHz system built in mid-2000.
Was running Windows XP Pro SP1 like a champ.

Thank you!
--Ben
Comment 1 Benjamin W. Slivka 2006-09-05 02:20:46 EDT
Created attachment 135527 [details]
The sound configuration log file
Comment 2 Martin Stransky 2006-09-11 07:14:01 EDT
Hm, log file looks fine.... You can check the latest drivers - how-to is here:

http://people.redhat.com/stransky/alsa/

But I recommend you to report it to ALSA project
(https://bugtrack.alsa-project.org/alsa-bug/), community there could help...
Comment 3 Dave Russell 2006-09-24 12:26:52 EDT
Just to note that I'm seeing a similar situation in FC6 Test 3.

The card worked fine in FC5, but is not showing up correctly in FC6 Test 3.

Will attempt to check the latest drivers.

In the meantime here are a few logs that may assist with the problem.
Comment 4 Dave Russell 2006-09-24 12:27:52 EDT
Created attachment 137017 [details]
scsconfig.log
Comment 5 Dave Russell 2006-09-24 12:28:22 EDT
Created attachment 137018 [details]
scsrun.log
Comment 6 Dave Russell 2006-09-25 02:03:27 EDT
Followed your how-to and updated to the latest tarballs linked there, no
difference I'm afraid.

Parts of gnome/linux seem to think there is a sound card installed, but clicking
on the volume control icon on the gnome panel results in a "you do not have a
sound card installed" type message.

I also rebuild the srpm for both of the alsa libs and tools and upgraded them.

No change.
Comment 7 Martin Stransky 2006-10-03 10:53:40 EDT
(In reply to comment #6)

There is the problem:

ACPI: PCI interrupt for device 0000:00:0a.0 disabled
EMU10K1_Audigy: probe of 0000:00:0a.0 failed with error -5

driver for your card have not loaded properly.

Please report it to the ALSA project (www.alsa-project.org), they're authors of
sound driver and attach scsconfig.log there.

Note You need to log in before you can comment on or make changes to this bug.