Bug 205185 - Oops on smp hibernate (Turion X2 laptop)
Summary: Oops on smp hibernate (Turion X2 laptop)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-05 11:48 UTC by Trever Adams
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.18-1.2759
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 20:09:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oops shot 1 (591.60 KB, image/jpeg)
2006-09-05 11:54 UTC, Trever Adams
no flags Details
Oops shot 2 (567.24 KB, image/jpeg)
2006-09-05 11:56 UTC, Trever Adams
no flags Details
Oops shot 3 (616.67 KB, image/jpeg)
2006-09-05 11:58 UTC, Trever Adams
no flags Details
Oops shot 4 (550.40 KB, image/jpeg)
2006-09-05 11:59 UTC, Trever Adams
no flags Details
Oops shot 5 (560.32 KB, image/jpeg)
2006-09-05 12:00 UTC, Trever Adams
no flags Details
Oops shot 6 (598.00 KB, image/jpeg)
2006-09-05 12:01 UTC, Trever Adams
no flags Details
Oops shot 7 (2.48 MB, image/jpeg)
2006-09-05 12:04 UTC, Trever Adams
no flags Details
Oops shot 8 (2.51 MB, image/jpeg)
2006-09-05 12:06 UTC, Trever Adams
no flags Details
Oops shot 9 (last one, sorry for the update spam) (2.48 MB, image/jpeg)
2006-09-05 12:08 UTC, Trever Adams
no flags Details

Description Trever Adams 2006-09-05 11:48:57 UTC
Description of problem:
I get this very consistently if I remove a few modules (or don't have them
loaded) on pm-hibernate. I have not run X yet when this happens, but it still
may be related to the xorg nv problem found elsewhere. Unforunately I have to do
screenshots, some of these may be too blurry, if they are, let me know and I
will redo those as necessary (will be later today). Each screen is half repeated
in the next due to the way linux does pgup/pgdown.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2617.2.1.fc6

How reproducible:
Very repeatable

Steps to Reproduce:
1. Remove sound and usb modules and all ethernet modules
2. Execute pm-hibernate
  
Actual results:
Oops as shown (locking and bad dereferencing in rwsem I think it was).

Expected results:
Should work fine.

Additional info:

Comment 1 Trever Adams 2006-09-05 11:54:07 UTC
Created attachment 135536 [details]
Oops shot 1

Comment 2 Trever Adams 2006-09-05 11:56:11 UTC
Created attachment 135537 [details]
Oops shot 2

Comment 3 Trever Adams 2006-09-05 11:58:17 UTC
Created attachment 135538 [details]
Oops shot 3

Comment 4 Trever Adams 2006-09-05 11:59:17 UTC
Created attachment 135539 [details]
Oops shot 4

Comment 5 Trever Adams 2006-09-05 12:00:27 UTC
Created attachment 135540 [details]
Oops shot 5

Comment 6 Trever Adams 2006-09-05 12:01:46 UTC
Created attachment 135541 [details]
Oops shot 6

Comment 7 Trever Adams 2006-09-05 12:04:21 UTC
Created attachment 135542 [details]
Oops shot 7

Comment 8 Trever Adams 2006-09-05 12:06:05 UTC
Created attachment 135543 [details]
Oops shot 8

Comment 9 Trever Adams 2006-09-05 12:08:22 UTC
Created attachment 135544 [details]
Oops shot 9 (last one, sorry for the update spam)

Comment 10 Trever Adams 2006-10-11 20:09:02 UTC
As noted by Peter Jones of Redhat, this is fixed with kernel 2.6.18-1.2759. I
tested it just a moment ago. Marking closed. (Stupid hibernate/resume eats 10%
of my battery.)


Note You need to log in before you can comment on or make changes to this bug.