Bug 205195 - Problem when writing tapes with an odd block size
Problem when writing tapes with an odd block size
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 08:45 EDT by Mike Aerts
Modified: 2012-04-24 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEL 4 U4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 11:42:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
is the output of the dmesg command contains version of system and error message of device driver (19.43 KB, text/plain)
2006-09-05 08:45 EDT, Mike Aerts
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 113737 None None None Never

  None (edit)
Description Mike Aerts 2006-09-05 08:45:41 EDT
Description of problem:
When writing a block with an odd size I get the error message
sym0:1:0:extraneous data discarded.
sym0:1:0:ODD transfer in DATA OUT phase.
The SCSI card is a LSI8751D HVD HBA 
02:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 04)
02:03.0 Class 0100: 1000:000f (rev 04)

And the tape deice to which I write is an IBM 3490 C22 drive
Vendor: IBM       Model: 03490C2203490C22  Rev: 45
No problems when write even sized blocks to this device but I get the following
error each time I write an odd sized datablock

sym0:1:0:extraneous data discarded.
sym0:1:0:ODD transfer in DATA OUT phase.
sym0:1:0:COMMAND FAILED (87 0 9).
st0: Error 70000 (sugg. bt 0x0, driver bt 0x0, host bt 0x7).

I found a reference to a similar problem in RHN with Bug ID 113737 but was not
able to access it.

Version-Release number of selected component (if applicable):

Linux version 2.6.9-34.ELsmp (bhcompile@hs20-bc1-7.build.redhat.com) (gcc
version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 SMP Fri Feb 24 16:54:53 EST 2006
with corresponding version of sym53cxx and st

How reproducible:
Happens every time you write an odd sized block to tape.

Steps to Reproduce:
1. Write an odd sized block to the tape.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Aerts 2006-09-05 08:45:41 EDT
Created attachment 135549 [details]
is the output of the dmesg command contains version of system and error message of device driver
Comment 2 Mike Aerts 2006-09-05 11:02:29 EDT
Problem has been solved by changing the width to 8 bit with the command
echo setwide 1 0 >/proc/scsi/sym53c8xx/0

So its not a bug, sorry.
Comment 4 Tom Coughlan 2007-02-08 11:42:43 EST
This problem may have been solved by the patch in BZ 167366. See:

http://marc.theaimsgroup.com/?l=linux-scsi&m=113976171919074&w=2

That fix is in RHEL 4 U4. 

I will close this, since there is a workaround in comment 2, regardless. 

Note You need to log in before you can comment on or make changes to this bug.