Bug 205206 - File conflicts in gaim
File conflicts in gaim
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:14 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 13:17:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:14:33 EDT
Description of problem:

        file /usr/include/gaim/config.h from install of
gaim-devel-2.0.0-0.11.beta3.fc6 conflicts with file from package
gaim-devel-2.0.0-0.11.beta3.fc6
Comment 1 Mark Doliner 2006-09-05 12:29:49 EDT
Uh, aren't those the same package?  What are you doing to trigger this problem?
 "rpm -i"?  yum update?
Comment 2 Bill Nottingham 2006-09-05 13:36:33 EDT
One is x86_64, one is i386. Doing yum install gaim-devel.i386 when only
gaim-devel.x86_64 is installed should trigger it.
Comment 3 Mark Doliner 2006-09-05 14:13:47 EDT
Ohhhh, I see
Comment 4 Stu Tomlinson 2006-09-29 16:24:10 EDT
Fixed upstream in SVN, will be fixed in 2.0.0 beta4
Comment 5 Warren Togami 2006-10-04 04:28:55 EDT
Stu,

Which patch specifically solved this problem?  I'd rather include this small
patch for FC6 rather than rebase the entire version.  We have no time to test
the latter.
Comment 6 Stu Tomlinson 2006-10-04 10:45:40 EDT
It was actually a couple of patches separated by other patches. Also it involves
patching Makefile.am which would require juggling with autotools to get it
patched/built.
Fortunately the fix is trivial - simply don't package config.h (eg. rm it in
%install) and patch it out of the one Gaim header that was incorrectly
#including it:
http://svn.sourceforge.net/viewvc/gaim/trunk/gtk/gtkpluginpref.h?r1=16855&r2=17398&view=patch
That patch won't apply as-is because the file was src/gtkpluginpref.h in beta3,
but it's clear what to do.

Note You need to log in before you can comment on or make changes to this bug.