Bug 205207 - libintl.jar files multilib conflict
libintl.jar files multilib conflict
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: multilibdevel 222156
  Show dependency treegraph
 
Reported: 2006-09-05 10:15 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 21:27:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:15:33 EDT
Description of problem:

        file /usr/share/gettext/libintl.jar from install of
gettext-devel-0.14.6-2.fc6 conflicts with file from package
gettext-devel-0.14.6-2.fc6


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stu Tomlinson 2006-09-29 16:18:13 EDT
this is not a Gaim bug (and I don't have permission to re-assign it to gettext)
Comment 2 Jens Petersen 2006-09-29 23:46:20 EDT
# yum install gettext-devel
:
Installing:
 gettext-devel           i386       0.14.6-2.fc6     development       1.0 M
 gettext-devel           x86_64     0.14.6-2.fc6     development       1.0 M
:
  Installing: gettext-devel                ######################### [3/4] 
  Installing: gettext-devel                ######################### [4/4] 

Installed: gettext-devel.i386 0:0.14.6-2.fc6 gettext-devel.x86_64 0:0.14.6-2.fc6
Dependency Installed: cvs.x86_64 0:1.11.22-4 gettext.i386 0:0.14.6-2.fc6
Complete!
[root@box23 petersen]# rpm -V gettext-devel.i386
.......T   /usr/include/gettext-po.h
.......T   /usr/share/gettext/ABOUT-NLS
..5....T   /usr/share/gettext/libintl.jar
.......T   /usr/share/gettext/msgunfmt.tcl
.......T d /usr/share/man/man3/bind_textdomain_codeset.3.gz
.......T d /usr/share/man/man3/bindtextdomain.3.gz
.......T d /usr/share/man/man3/dcgettext.3.gz
.......T d /usr/share/man/man3/dcngettext.3.gz
.......T d /usr/share/man/man3/dgettext.3.gz
.......T d /usr/share/man/man3/dngettext.3.gz
.......T d /usr/share/man/man3/gettext.3.gz
.......T d /usr/share/man/man3/ngettext.3.gz
.......T d /usr/share/man/man3/textdomain.3.gz


So this is referring to the md5 sum difference above?
Comment 3 Jens Petersen 2006-10-02 04:17:23 EDT
Hmm, the the files in the .jar zip archives have identical md5 and datestamps:
the problem seems to be the zip files themselves are different,
perhaps some datestamp or something is causing that?

I tested this with fastjar, generating two .jar files of the same directory
directory and indeed they get different md5sum's.

Let me pass this over to the Tools team for comments.
Comment 4 Jakub Jelinek 2006-10-02 04:37:14 EDT
If you tell fastjar to create META-INF, that has its own timestamp too.
redhat-rpm-config has /usr/lib/rpm/redhat/brp-java-repack-jars
script for it, if you ensure /usr/bin/zip and /usr/bin/unzip are installed
in the buildroot (adjust BuildRequires), then it should automatically do the
right thing.
Comment 5 Jens Petersen 2006-10-02 05:00:21 EDT
Fixing in 0.14.6-3.fc6.
Comment 6 Jeremy Katz 2006-10-02 17:50:51 EDT
Still seems to be a problem --

[katzj@porkchop RPMS]$ ~/multilib-cmp.py gettext-devel-0.14.6-3.fc6.*
File conflict for /usr/share/gettext/libintl.jar in gettext-devel-0.14.6-3.fc6
Comment 7 Jens Petersen 2006-10-04 05:02:47 EDT
[cc redhat-rpm-config owner]

The brp-java-repack-jars seems to work fine from the commandline,
but not from rpmbuild afaict.
Comment 8 Jens Petersen 2006-10-26 22:55:08 EDT
FWIW gettext-0.15-1.fc7 no longer has a jar file.
Comment 9 Jens Petersen 2007-01-10 22:16:54 EST
The problem seems to be that the directories in the .jar files have different
timestamps and hence they have different md5sum's.
Comment 10 Jens Petersen 2007-01-11 01:54:22 EST
Actually I take that back there are no directories in the .jar files:
guess there must be some other timestamp in the .jar.

I don't see an easy way to fix this since every .zip file generated
seems to have a different md5sum.
Comment 11 Jens Petersen 2007-01-11 01:57:37 EST
A simple workaround I can see would be to move libintl.jar to %_libdir/gettext/.
Comment 12 Bill Nottingham 2007-01-11 10:55:39 EST
You might check to see what, if anything, the java or libgcj packages do.
Comment 13 Jens Petersen 2007-01-14 20:47:56 EST
Fixing in gettext-0.14.6-4.fc6.

Note You need to log in before you can comment on or make changes to this bug.