Bug 205216 - File conflicts
File conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On: 192690
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:22 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: java-1.4.2-gcj-compat-1.4.2.0-40jpp.108
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 19:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:22:22 EDT
Description of problem:

        file /usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/lib/tools.jar from install of
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105 conflicts with file from package
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105
        file /usr/lib/python2.4/site-packages/aotcompile.pyc from install of
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105 conflicts with file from package
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105
        file /usr/lib/python2.4/site-packages/aotcompile.pyo from install of
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105 conflicts with file from package
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.105
Comment 1 Thomas Fitzsimmons 2006-09-05 14:40:22 EDT
The tools.jar conflict will be fixed by the brp script attached to this bug report:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192690

Shouldn't the aotcompile.py{c,o} files be handled by the python brp script?
Comment 2 Thomas Fitzsimmons 2006-09-07 19:02:24 EDT
I worked around the .pyc/.pyo problem with:

touch --reference=aotcompile.py.in aotcompile.py

after make.

And Ben's brp-java-repack-jars landed in dist-fc6, so the tools.jar conflict is
also fixed.

I also fixed a conflict in the -javadoc sub-package caused by a rounding problem
in i386 gjdoc/libgcj, and a conflict in the base package where
/usr/bin/rebuild-gcj-db was referencing libdir.

Note You need to log in before you can comment on or make changes to this bug.