Bug 205219 - File conflicts in libbtctl
File conflicts in libbtctl
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk-doc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: Reopened
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:23 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 21:31:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:23:51 EDT
Description of problem:

        file /usr/share/gtk-doc/html/libbtctl/BtctlController.html from install
of libbtctl-devel-0.6.0-9.1 conflicts with file from package
libbtctl-devel-0.6.0-9.1
        file /usr/share/gtk-doc/html/libbtctl/BtctlObex.html from install of
libbtctl-devel-0.6.0-9.1 conflicts with file from package libbtctl-devel-0.6.0-9.1
        file /usr/share/gtk-doc/html/libbtctl/ch01.html from install of
libbtctl-devel-0.6.0-9.1 conflicts with file from package libbtctl-devel-0.6.0-9.1
        file /usr/share/gtk-doc/html/libbtctl/ch02.html from install of
libbtctl-devel-0.6.0-9.1 conflicts with file from package libbtctl-devel-0.6.0-9.1
        file /usr/share/gtk-doc/html/libbtctl/ch03.html from install of
libbtctl-devel-0.6.0-9.1 conflicts with file from package libbtctl-devel-0.6.0-9.1
        file
/usr/share/gtk-doc/html/libbtctl/libbtctl-btctl-discovery-source.html from
install of libbtctl-devel-0.6.0-9.1 conflicts with file from package
libbtctl-devel-0.6.0-9.1
        file /usr/share/gtk-doc/html/libbtctl/libbtctl-obex-server-source.html
from install of libbtctl-devel-0.6.0-9.1 conflicts with file from package
libbtctl-devel-0.6.0-9.1
Comment 1 Harald Hoyer 2006-09-25 10:02:31 EDT
err... you cannot install an already installed package
Comment 2 Karsten Hopp 2006-09-25 10:07:35 EDT
I can add the missing information as I got one of those reports, too:
This is a multiarch problem, the files from the 64bit packages differ from 
those of the 32bit rpm and this results in file conflicts.
Comment 3 Harald Hoyer 2006-09-25 10:17:05 EDT
<meta name="generator" content="GTK-Doc V1.6 (XML mode)">
Comment 4 Harald Hoyer 2006-09-25 10:19:09 EDT
gtk-doc should generate equal documents on all archs
Comment 5 Harald Hoyer 2006-09-25 10:23:50 EDT
AFAIRC, the ids in <a name="id2544124"> differ...
Comment 6 Matthias Clasen 2006-09-25 10:28:58 EDT
yes, it would be nice. however, since this is hidden in gobs of xsl in the
docbook stylesheets it is not a quick fix. The official response is that
upstream tarball are supposed to contain formatted api docs.
Comment 7 Matthias Clasen 2008-02-06 21:31:00 EST
I'm not going to be able to do anything about this.

Note You need to log in before you can comment on or make changes to this bug.