Bug 205221 - File conflicts
File conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpfm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: William Cohen
:
: 222707 (view as bug list)
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:25 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.2-0.060621.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 16:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-05 10:25:36 EDT
Description of problem:

        file /usr/lib/libpfm.a from install of libpfm-devel-3.2-0.060621.8.1
conflicts with file from package libpfm-devel-3.2-0.060621.8.1

Shouldn't that be somewhere else on x86-64?
Comment 1 William Cohen 2006-09-18 14:57:52 EDT
You should only install one libpfm on the machine. You wouldn't be using a
32-bit libpfm on a 64-bit machine.

The 64bit version of the software should be installing the libraries in the
/usr/lib64 to be consistent with other packages.
Comment 2 Bill Nottingham 2006-09-18 15:01:29 EDT
Both are installed for development purposes.
Comment 3 William Cohen 2006-09-19 16:02:15 EDT
Took a closer look at what is going on with libpfm. libpfm has a file config.mk
included into the Makefile. The config.mk has the following line that hardcodes
the directory:

PFMLIBDIR=$(TOPDIR)/lib

Have workaround in the libpfm.spec for 3.2-0.060621.10 to move the libraries
into the correct place.
Comment 4 William Cohen 2007-01-16 10:16:50 EST
*** Bug 222707 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.