Bug 205233 - File conflicts in SDL
File conflicts in SDL
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-09-05 10:33 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.10-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-12 09:26:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff between the 2 conflicting header files (1012 bytes, text/plain)
2006-10-15 12:15 EDT, Hans de Goede
no flags Details

  None (edit)
Description Bill Nottingham 2006-09-05 10:33:30 EDT
Description of problem:

        file /usr/include/SDL/SDL_config.h from install of SDL-devel-1.2.10-6.2
conflicts with file from package SDL-devel-1.2.10-6.2
Comment 1 Hans de Goede 2006-10-15 12:16:05 EDT
Created attachment 138530 [details]
diff between the 2 conflicting header files

I just did a diff between the 2 conflicting header files, and this is it. The
main difference seems to be caused by bug 207903.

With 207903 resolved the only remaining problem is:
@@ -300,7 +300,7 @@
 
 /* Enable assembly routines */
 #define SDL_ASSEMBLY_ROUTINES 1
-#define SDL_HERMES_BLITTERS 1	
+/* #undef SDL_HERMES_BLITTERS */
 /* #undef SDL_ALTIVEC_BLITTERS */
 
 #endif /* _SDL_config_h */

Which can be easily solved by making this:
 
 /* Enable assembly routines */
 #define SDL_ASSEMBLY_ROUTINES 1
 #ifdef __i386__
 #define SDL_HERMES_BLITTERS 1	
 #endif
 /* #undef SDL_ALTIVEC_BLITTERS */
 
 #endif /* _SDL_config_h */

Let me know if you want me to take a closer look (as time permits) and send you
a patch.
Comment 2 Hans de Goede 2007-02-12 09:26:13 EST
This is fixed as of 1.2.10-8 which is available in updates, closing.

Note You need to log in before you can comment on or make changes to this bug.