Bug 2052416 - The autogenerated VM name has produced some concern and it could be an issue at some point
Summary: The autogenerated VM name has produced some concern and it could be an issue ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.10
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.10.z
Assignee: Gilad Lekner
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 2102302
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-09 08:56 UTC by Guohua Ouyang
Modified: 2022-07-20 07:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-20 07:46:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 11778 0 None Merged Bug 2052416: fix offensive vm names 2022-07-11 07:43:51 UTC
Red Hat Product Errata RHBA-2022:5568 0 None None None 2022-07-20 07:46:33 UTC

Description Guohua Ouyang 2022-02-09 08:56:46 UTC
Description of problem:
The VM name is auto-generated by using an external library, VM name "demo-jewish-spoonable" and "test-islamic-beetle" produced some concerns while doing a demo in a meeting. We need to avoid using offensive word in the VM name.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2022-02-09 12:33:20 UTC
Fixed upstream, we may need to bump imported version
https://github.com/andreasonny83/unique-names-generator/issues/45

Comment 6 errata-xmlrpc 2022-07-20 07:46:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:5568


Note You need to log in before you can comment on or make changes to this bug.