Bug 2052469 - Filtering templates by boot source availability does not work
Summary: Filtering templates by boot source availability does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.10.z
Assignee: Ugo Palatucci
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 2102302
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-09 10:42 UTC by Fabian Deutsch
Modified: 2022-11-09 10:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-09 10:51:02 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Empty results if "boot source" is selected (40.09 KB, image/png)
2022-02-09 10:42 UTC, Fabian Deutsch
no flags Details
Same page without the "boot source" filter, but all namespaces (79.85 KB, image/png)
2022-02-09 10:42 UTC, Fabian Deutsch
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 12164 0 None open Bug 2052469: Filter template list for boot source available 2022-10-12 14:48:19 UTC
Red Hat Product Errata RHBA-2022:7298 0 None None None 2022-11-09 10:51:05 UTC

Description Fabian Deutsch 2022-02-09 10:42:13 UTC
Created attachment 1860056 [details]
Empty results if "boot source" is selected

Description of problem:
When creating a VM, filtering a VM by boot source does not work.
In the attached screenshot "Boot source" is selected, but no templates are shown - even with all namespaces selected.

Version-Release number of selected component (if applicable):
4.10

How reproducible:
Always

Steps to Reproduce:
1. Create  VM
2. Filter by boot source availability
3.

Actual results:
No templates are shown

Expected results:
All templates with boot source in 4.10 (rhel 8, rhel 9, cetos 8, centos 9, fedora) should be shown

Additional info:

Comment 1 Fabian Deutsch 2022-02-09 10:42:39 UTC
Created attachment 1860057 [details]
Same page without the "boot source" filter, but all namespaces

Comment 7 Guohua Ouyang 2022-11-02 08:37:04 UTC
verified on 4.10.0-0.nightly-2022-11-01-183141

Comment 9 errata-xmlrpc 2022-11-09 10:51:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.40 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7298


Note You need to log in before you can comment on or make changes to this bug.