Bug 205257 - alacarte doesn't modify sub items in system menu.
alacarte doesn't modify sub items in system menu.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alacarte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-09-05 12:01 EDT by sangu
Modified: 2009-03-30 07:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.10.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 01:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-09-05 12:01:24 EDT
Description of problem:
alacarte doesn't  modify sub items in system menu.
$alacrte
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Alacarte/MainWindow.py", line 372, in
on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 208, in
setVisible
    menu_xml = self.__getXmlMenu(self.__getPath(item), dom, dom)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 475, in
__getXmlMenu
    node = self.__addXmlMenuElement(element, name, dom)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 486, in
__addXmlMenuElement
    return element.appendChild(node)
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1548, in
appendChild
    raise xml.dom.HierarchyRequestErr(
xml.dom.HierarchyRequestErr: two document elements disallowed


Version-Release number of selected component (if applicable):
0.10.0-1.fc6

How reproducible:
always

Steps to Reproduce:
1. click system menu on alacarte
2. check or uncheck item
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2006-09-05 14:29:22 EDT
Hmm, I have been able to reproduce this once, but now it does not happen anymore.
Can you reliably reproduce this ?
Comment 2 Matthias Clasen 2006-09-06 12:58:00 EDT
Related upstream bug containing a way I found to reproduce this:

http://bugzilla.gnome.org/show_bug.cgi?id=354654
Comment 3 sangu 2006-10-07 04:01:20 EDT
Please see also :http://bugzilla.gnome.org/show_bug.cgi?id=355828 

bug 205257 seems to be fixed in alacarte 0.10.1 

Note You need to log in before you can comment on or make changes to this bug.