Bug 205277 - c++ ICE on x86_64: output_operand: invalid expression as operand
c++ ICE on x86_64: output_operand: invalid expression as operand
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: OLPCTracker
  Show dependency treegraph
 
Reported: 2006-09-05 14:56 EDT by Dan Williams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 10:12:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2006-09-05 14:56:27 EDT
gcc-4.1.1-20

ICE when compiling some bits of Csound's FLTK GUI.

Full build logs here:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/16257-csound-5.03.0-2.fc6/x86_64/build.log

preprocessed output here:
http://people.redhat.com/dcbw/ccF3s5hz.out.bz2

Probably bad C++, but of course it shouldn't ICE.
Comment 1 Dan Williams 2006-09-05 14:59:09 EDT
Error text from end of log:

frontends/fltk_gui/CsoundGlobalSettings.cpp: In constructor
'CsoundGlobalSettings::CsoundGlobalSettings()':
frontends/fltk_gui/CsoundGlobalSettings.cpp:47: internal compiler error:
output_operand: invalid expression as operand
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
{standard input}: Assembler messages:
{standard input}:4081: Warning: end of file not at end of a line; newline inserted
Preprocessed source stored into /tmp/cc3qhnW4.out file, please attach this to
your bugreport.
scons: *** [frontends/fltk_gui/CsoundGlobalSettings.o] Error 1
scons: building terminated because of errors.
error: Bad exit status from /var/tmp/rpm-tmp.76173 (%build)
Comment 2 Jakub Jelinek 2006-09-08 09:25:47 EDT
-gstabs ?  On x86-64?  That obviously can't work even if gcc didn't ICE,
as Stabs is a pure 32-bit debug format.
Comment 3 Jakub Jelinek 2006-09-08 10:12:49 EDT
Guess a targetm.delegimitize_address call inserted into selected places in
dbxout.c would help, but I'm not interested in spending too much time on
this broken untested debug format.

Note You need to log in before you can comment on or make changes to this bug.