This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 205310 - First Autotools Build Takes Very Long Time Refreshing
First Autotools Build Takes Very Long Time Refreshing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-05 18:48 EDT by Jeff Johnston
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 18:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnston 2006-09-05 18:48:01 EDT
When using the Autotools plugin to build a relatively large C project (e.g.
newlib) for the first time, there is a stage between configuration and build
that is called refresh.  This stage takes a very long time to complete and there
is no real feedback on %complete (0 or done).

The cause of the delay should be investigated to see if it can be addressed and
if not, some better form of progress should be displayed.
Comment 1 Jeff Johnston 2007-02-27 18:02:48 EST
Problem is actually caused when populating the Make Target dialog for Build
Special Targets.  The interface provided only allows one Make Target at a time
to be added and it ends up rewriting .cdtproject.  This causes events to be
triggered.  Fix was to added to Autotools 0.0.8.1 to provide new interface. 
Time between configure and build for newlib project goes down from >10 minutes
to about 4 seconds.

Note You need to log in before you can comment on or make changes to this bug.