Bug 205317 - yum crashes with "IndexError: list index out of range"
yum crashes with "IndexError: list index out of range"
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2006-09-05 19:33 EDT by James Ralston
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-10 18:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output of "yum -d 10 update seamonkey-chat" (48.95 KB, text/plain)
2006-09-21 12:26 EDT, James Ralston
no flags Details
yum-2.9.6 output of "yum -d 10 update seamonkey-chat" (46.23 KB, text/plain)
2006-09-22 14:33 EDT, James Ralston
no flags Details

  None (edit)
Description James Ralston 2006-09-05 19:33:54 EDT
I'm running yum-2.6.1-0.fc5 on an x86_64 RHEL4 box.  (I rebuilt from the SRPM

This setup has worked fine for many months, but now yum is crashing on multiple
package updates that were part of the U4 release.

An example:

$ yum update 'openldap*'
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
rhel                                                                 [1/2]
sei-rhel                                                             [2/2]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for openldap-servers to pack into transaction set.
openldap-servers-2.2.13-6 100% |=========================|  37 kB    00:00     
---> Package openldap-servers.x86_64 0:2.2.13-6.4E set to be updated
---> Downloading header for openldap-devel to pack into transaction set.
openldap-devel-2.2.13-6.4 100% |=========================|  53 kB    00:00     
---> Package openldap-devel.x86_64 0:2.2.13-6.4E set to be updated
---> Package openldap.x86_64 0:2.2.13-6.4E set to be updated
---> Package openldap-clients.x86_64 0:2.2.13-6.4E set to be updated
---> Downloading header for openldap-servers-sql to pack into transaction set.
openldap-servers-sql-2.2. 100% |=========================|  31 kB    00:00     
---> Package openldap-servers-sql.x86_64 0:2.2.13-6.4E set to be updated
--> Running transaction check
--> Processing Dependency: openldap = 2.2.13-4 for package: compat-openldap
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
  File "/usr/share/yum-cli/yummain.py", line 138, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "__init__.py", line 401, in buildTransaction
  File "depsolve.py", line 226, in resolveDeps
  File "depsolve.py", line 357, in _processReq
  File "depsolve.py", line 418, in _requiringFromInstalled
  File "__init__.py", line 1479, in getInstalledPackageObject
IndexError: list index out of range

I didn't see a crash quite like this in the existing bug reports that I skimmed

Also, this crash only seems to be happening on x86_64.  I do *not* see the
problem on an i386 box.

I tried the latest development version (2.9.5), but it crashes as well.  (Again,
only on x86_64; i386 is fine.)
Comment 1 James Ralston 2006-09-06 12:32:45 EDT
I also have a yum bugzilla report open for this bug:


(I can't create an external Bugzilla reference, because the Duke/yum bugzilla
site doesn't appear to be one of the options.)
Comment 2 Seth Vidal 2006-09-06 12:34:44 EDT
yes, we know. the same people get them in both places.

no need to file it twice.
Comment 3 James Ralston 2006-09-08 21:59:16 EDT

(Some people, like Mike Harris, always want to move bugs upstream if possible,
so I wasn't sure.)
Comment 4 Jeremy Katz 2006-09-18 17:07:07 EDT
What's the output of 'rpm -qa | grep openldap'?
Comment 5 James Ralston 2006-09-21 12:26:44 EDT
Created attachment 136877 [details]
output of "yum -d 10 update seamonkey-chat"

I can't reproduce the openldap problem (as I already upgraded those packages),
but here's another example caused by trying to upgrade seamonkey-chat.

The package breakdown is:

$ rpm -qa --qf '%{name}-%{version}-%{release}.%{arch}.rpm\n' | grep -i
seamonkey | sort
Comment 6 Jeremy Katz 2006-09-22 00:42:16 EDT
Can you try with yum 2.9.6 and see if this still happens?  It looks to me like
things should be fixed there (not that I then see an easy backport, but I want
to at least see that things are fixed in the current code)
Comment 7 James Ralston 2006-09-22 14:33:07 EDT
Created attachment 136961 [details]
yum-2.9.6 output of "yum -d 10 update seamonkey-chat"

I rebuilt yum-2.9.6-1.src.rpm from Fedora Development for RHEL4, but it fails
in a different manner (see the attached output).

I'm using createrepo-0.4.4-0.2 on the repo server (also a RHEL4 box).  Am I
missing newer bits that yum-2.9.6 needs?
Comment 8 Seth Vidal 2006-09-24 18:38:40 EDT
okay - running 2.9.6 on rhel 4's rpm probably won't work.

so that won't be a good test.
Comment 9 James Ralston 2006-10-10 17:46:44 EDT

I'm going to open a service request for Red Hat to backport the yum
infrastructure in RHEL5 to RHEL4, but I'm not going to hold my breath.

In the meantime, for sites like us who are going to put yum on RHEL4, what's
your recommendation for the best (as in, least likely to die/crash) version of
yum to use?
Comment 10 Seth Vidal 2006-10-10 18:35:36 EDT
you should run yum 2.4.3 on rhel4.

2.6 _might_ work - but I can't guarantee that.
Comment 11 James Ralston 2006-10-12 16:40:13 EDT
Well, if 2.6 worked, then I probably wouldn't have filed this in the first
place.  ;)

But regardless: noted; thanks.

Note You need to log in before you can comment on or make changes to this bug.