Bug 2053236 (CVE-2022-22754) - CVE-2022-22754 Mozilla: Extensions could have bypassed permission confirmation during update
Summary: CVE-2022-22754 Mozilla: Extensions could have bypassed permission confirmatio...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2022-22754
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2051916 2051917 2051918 2051919 2051920 2051921 2051922 2051926 2051927 2051928 2051929 2051930 2051931 2051932 2053036 2054257
Blocks: 2051914
TreeView+ depends on / blocked
 
Reported: 2022-02-10 18:43 UTC by Tomas Hoger
Modified: 2022-12-12 21:12 UTC (History)
5 users (show)

Fixed In Version: firefox 91.6, thunderbird 91.6
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Mozilla. The Mozilla Foundation Security Advisory describes this flaw as: If a user installed a particular type of extension, the extension could have auto-updated itself, and while doing so may have bypassed the prompt which grants the new version the new requested permissions.
Clone Of:
Environment:
Last Closed: 2022-02-14 10:17:24 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2022:0510 0 None None None 2022-02-14 08:50:40 UTC
Red Hat Product Errata RHSA-2022:0511 0 None None None 2022-02-14 08:46:11 UTC
Red Hat Product Errata RHSA-2022:0512 0 None None None 2022-02-14 08:42:41 UTC
Red Hat Product Errata RHSA-2022:0513 0 None None None 2022-02-14 08:29:55 UTC
Red Hat Product Errata RHSA-2022:0514 0 None None None 2022-02-14 09:06:58 UTC
Red Hat Product Errata RHSA-2022:0535 0 None None None 2022-02-15 10:32:22 UTC
Red Hat Product Errata RHSA-2022:0536 0 None None None 2022-02-15 10:36:26 UTC
Red Hat Product Errata RHSA-2022:0537 0 None None None 2022-02-15 10:33:55 UTC
Red Hat Product Errata RHSA-2022:0538 0 None None None 2022-02-15 10:50:23 UTC
Red Hat Product Errata RHSA-2022:0539 0 None None None 2022-02-15 10:17:41 UTC

Description Tomas Hoger 2022-02-10 18:43:58 UTC
If a user installed an extension of a particular type, the extension could have auto-updated itself and while doing so, bypass the prompt which grants the new version the new requested permissions.

External Reference:

https://www.mozilla.org/en-US/security/advisories/mfsa2022-05/#CVE-2022-22754

Comment 1 errata-xmlrpc 2022-02-14 08:29:53 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:0513 https://access.redhat.com/errata/RHSA-2022:0513

Comment 2 errata-xmlrpc 2022-02-14 08:42:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:0512 https://access.redhat.com/errata/RHSA-2022:0512

Comment 3 errata-xmlrpc 2022-02-14 08:46:08 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:0511 https://access.redhat.com/errata/RHSA-2022:0511

Comment 4 errata-xmlrpc 2022-02-14 08:50:37 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:0510 https://access.redhat.com/errata/RHSA-2022:0510

Comment 5 errata-xmlrpc 2022-02-14 09:06:56 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:0514 https://access.redhat.com/errata/RHSA-2022:0514

Comment 6 Product Security DevOps Team 2022-02-14 10:17:22 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2022-22754

Comment 8 errata-xmlrpc 2022-02-15 10:17:38 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Via RHSA-2022:0539 https://access.redhat.com/errata/RHSA-2022:0539

Comment 9 errata-xmlrpc 2022-02-15 10:32:19 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:0535 https://access.redhat.com/errata/RHSA-2022:0535

Comment 10 errata-xmlrpc 2022-02-15 10:33:53 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.2 Extended Update Support

Via RHSA-2022:0537 https://access.redhat.com/errata/RHSA-2022:0537

Comment 11 errata-xmlrpc 2022-02-15 10:36:24 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8.4 Extended Update Support

Via RHSA-2022:0536 https://access.redhat.com/errata/RHSA-2022:0536

Comment 12 errata-xmlrpc 2022-02-15 10:50:20 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2022:0538 https://access.redhat.com/errata/RHSA-2022:0538


Note You need to log in before you can comment on or make changes to this bug.