RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2053289 - FIPS provider doesn't block RSA encryption for key transport
Summary: FIPS provider doesn't block RSA encryption for key transport
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: openssl
Version: 9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Dmitry Belyavskiy
QA Contact: Hubert Kario
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks: 2091977
TreeView+ depends on / blocked
 
Reported: 2022-02-10 21:14 UTC by Hubert Kario
Modified: 2023-06-05 15:55 UTC (History)
4 users (show)

Fixed In Version: openssl-3.0.1-25.el9
Doc Type: Bug Fix
Doc Text:
.Cryptography not approved by FIPS no longer works in OpenSSL in FIPS mode Previously, cryptography that was not FIPS-approved worked in the OpenSSL toolkit regardless of system settings. Consequently, you could use cryptographic algorithms and ciphers that should be disabled when the system is running in FIPS mode, for example: * TLS cipher suites using the RSA key exchange worked. * RSA-based algorithms for public-key encryption and decryption worked despite using the PKCS #1 and SSLv23 paddings or using keys shorter than 2048 bits. This update contains fixes ensuring that cryptography not approved by FIPS no longer works in OpenSSL in FIPS mode.
Clone Of:
: 2091977 (view as bug list)
Environment:
Last Closed: 2023-06-05 15:55:43 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 2077884 1 medium CLOSED Small RSA keys work for some operations in FIPS mode 2023-10-08 06:12:29 UTC
Red Hat Issue Tracker CRYPTO-6315 0 None None None 2022-03-02 12:48:36 UTC
Red Hat Issue Tracker RHELPLAN-111973 0 None None None 2022-02-10 21:18:34 UTC

Internal Links: 2077884

Description Hubert Kario 2022-02-10 21:14:42 UTC
Description of problem:
When OpenSSL works in FIPS mode, and the user configuration overrides crypto policies the RSA key exchange works.

Version-Release number of selected component (if applicable):
openssl-3.0.1-7

How reproducible:
always

Steps to Reproduce:
1. switch system to FIPS mode
2. openssl s_server -key localhost.key -cert localhost.crt -rev -cipher @SECLEVEL=0:ALL:COMPLEMENTOFALL -ciphersuites TLS_AES_256_GCM_SHA384:TLS_AES_128_GCM_SHA256:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_128_CCM_SHA256:TLS_AES_128_CCM_8_SHA256
3. openssl s_client -tls1_2 -cipher AES128-SHA

Actual results:
Connection successful

Expected results:
Connection failed

Additional info:

Comment 1 Dmitry Belyavskiy 2022-02-11 15:38:47 UTC
Is it a difference between 140-2 and 140-3 or upstream bug?

Comment 2 Hubert Kario 2022-02-11 16:54:14 UTC
It's our policy thing: we have not allowed RSA key exchange in RHEL-8 in FIPS mode

Comment 3 Dmitry Belyavskiy 2022-02-11 16:56:45 UTC
But if you override the policy, the policy doesn't matter anymore...

Comment 4 Hubert Kario 2022-02-11 17:16:08 UTC
I meant the Security Policy of the module

Comment 5 Dmitry Belyavskiy 2022-02-11 17:19:49 UTC
Sorry, I don't get. If RSA encryption is not permitted by the standard we have to disable it. If it is our distribution-level policy, it is not inside the boundary so it's overwritable.

Comment 6 Hubert Kario 2022-02-22 16:21:54 UTC
It is not a mechanism that we will certify in the FIPS module.

Comment 23 Clemens Lang 2023-06-05 15:55:43 UTC
RHEL 9.1 contains openssl-3.0.1-43.el9_0.


Note You need to log in before you can comment on or make changes to this bug.