Bug 205336 - growisofs fails to fixate
growisofs fails to fixate
Status: CLOSED DUPLICATE of bug 208542
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 02:13 EDT by Jonathan Eskritt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 06:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Eskritt 2006-09-06 02:13:33 EDT
growisofs burns to the end of the iso (both when provided an iso or a directory
of files) but fails to fixate. It gives an error about reasource unavailable. 

with cdrecord I cn burn CDs but dvds fail to burn correctly, it burns to the end
and fixating take 0.2 seconds and I get a coaster.

I have 2 i386 machines on with a pioneer DVR-108 and the other with an LG
DVD+/-RW they both burn DVDs fine. This machine is a X2 X86_64 wit ha pioneer
DVR-111D 

I tried "cdrecord dev=/dev/dvd -fix" to fixate the disc to no avail. 

dvd+rw-tools-5.21.4.10.8-6.2.1
cdrecord-2.01.01.0.a03-3
kernel-2.6.17-1.2174_FC5

How reproducible:
everytime

Steps to Reproduce:
1. burn a dvd
  
Actual results:
dvds burn full length but fail to fixate

Expected results:
dvds should fixate and be mountable
Comment 1 Sammy 2006-09-07 12:06:46 EDT
I can confirm this as well. When I chose dao mode instead of tao it
did complete the fixate though!
Comment 2 Jonathan Eskritt 2006-09-09 02:23:49 EDT
I made an iso and burned it using cdrecord in dao mode as suggested above I get:

# cdrecord -v -dao dev=/dev/dvd disc.iso
Cdrecord-Clone 2.01.01a03-dvd (x86_64-unknown-linux-gnu) Copyright (C) 1995-2005
Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus may
      have bugs related to DVD issues that are not present in the original
      cdrtools. Please send bug reports or support requests to
      http://bugzilla.redhat.com/bugzilla The original cdrtools author should
      not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: '/dev/dvd'
devname: '/dev/dvd'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.85-RH '@(#)scsi-linux-sg.c      1.85 05/05/16 Copyright
1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'PIONEER '
Identifikation : 'DVD-RW  DVR-111D'
Revision       : '1.23'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0016
Profile: 0x0015
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using Session At Once (SAO) for DVD mode.
Using Session At Once (SAO) for DVD mode.
Using Session At Once (SAO) for DVD mode.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 1605632 = 1568 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  4120 MB
Total size:     4731 MB (468:46.30) = 2109473 sectors
Lout start:     4731 MB (468:48/23) = 2109473 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 157789 (35:05/64)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 185631
scsi_set_streaming
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is ON.
Turning BURN-Free off
BURN-Free is OFF.
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Starting new track at sector: 0
Track 01: 4120 of 4120 MB written (fifo 100%) [buf  75%]  30.1x.
Track 01: Total bytes read/written: 4320200704/4320200704 (2109473 sectors).
Writing  time:  799.995s
Average write speed  35.9x.
Min drive buffer fill was 60%
Fixating...
Fixating time:    0.231s
cdrecord: fifo had 68048 puts and 68048 gets.
cdrecord: fifo was 0 times empty and 8763 times full, min fill was 70%.


the disc fails to mount. dmesg gives:
cdrom: This disc doesn't have any tracks I recognize!
Comment 3 Harald Hoyer 2006-09-29 06:28:02 EDT

*** This bug has been marked as a duplicate of 208542 ***

Note You need to log in before you can comment on or make changes to this bug.