Bug 205350 - R-packages fail when uninstalling
R-packages fail when uninstalling
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 04:26 EDT by birger
Modified: 2008-05-06 12:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description birger 2006-09-06 04:26:41 EDT
Description of problem:
R-gnomeGUI, R-waveslim and R-wavethresh fail if they get dependency-uninstalled.

Version-Release number of selected component (if applicable):
R-vaweslim 1.5-3.fc5
R-wavethresh 2.2-3.fc5
R-gnomeGUI 2.1.0-5.fc5

How reproducible:
always

Steps to Reproduce:
1. Install R and these packages
2. yum uninstall R
3.
  
Actual results:
When R uninstalls, it uninstalls R before uninstalling the other modules.
The post-processing of the 3 modules mentioned fails when R is gone, and they
don't get uninstalled.

Expected results:
When R has already been uninstalled these modules should not care that they
cannot run the post-processing.

Additional info:
I have to reinstall R, and then uninstall these modules before uninstalling R to
get them removed.
Comment 1 Tom "spot" Callaway 2006-09-06 10:49:43 EDT
Pretty sure this is an rpm failure, not R's fault. These packages Require: R
already. Pointing this to rpm.
Comment 2 Jeff Johnson 2006-09-06 19:04:52 EDT
I did
    # yum instal R R-vaweslim R-wavethresh R-gnomeGUI

(which did not find R-waveslim or R-gnomeGUI, clearly a yum or repo config deficiency, not an rpm 
problem).

I tried
    # yum remove R
which discovered that R-wavethresh needed to be removed as well. Good! 
Unfortunatley yum chose to order the transaction as erase R, then R-wavethresh,
reproducing the reported problem, that scriptlets fail because R is already gone.

I then installed R and R-wavethresh using "yum install" and ran
    # rpm -e R R-wavethresh
which worked.

I repeated the "yum install" and did (note reversed args)
    # rpm -e R-wavethresh R
which worked.

All with rpm-4.4.7.

So its a yum, not an rpm problem.

UPSTREAM or back to yum, your call. The rpm in FC has not erasure ordering.

Comment 3 birger 2006-10-11 03:32:00 EDT
I just think that if R is already gone when R-wavethresh is uninstalling the
uninstall of R-wavethresh shouldn't fail. It seems wrong that it should refuse
to uninstall because it cannot deregister itself from a package that has already
been uninstalled.

So even if I think there is a bug in yum here, I still think the logic in the
wavethresh rpm is also wrong.
Comment 4 Jeff Johnson 2006-10-12 04:22:03 EDT
You are correct that the issue(s) of erasure ordering
by yum (or rpm) could be avoided if the R-wavethresh
scriptlets were written differently (and more robustly).
Comment 5 Red Hat Bugzilla 2007-08-21 01:25:35 EDT
User pnasrat@redhat.com's account has been closed
Comment 6 Panu Matilainen 2007-08-22 02:33:37 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 7 Panu Matilainen 2007-08-28 02:35:43 EDT
FC5 is EOL, but is this still an issue with later releases? There have been some
fixes for erasure ordering since then...
Comment 8 birger 2007-11-14 15:54:41 EST
I dont know, as I have changed employer and don't work on those packages anymore :-)

Sorry I can't be of much help on this bug anymore.
Comment 9 Bug Zapper 2008-04-03 23:40:02 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 10 Bug Zapper 2008-05-06 12:18:19 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.