Bug 2054016 - SDDM in Fedora 36 - menus do not open properly and cause a strobe effect, plus minor cosmetic issues
Summary: SDDM in Fedora 36 - menus do not open properly and cause a strobe effect, plu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 36
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
: 2055627 2060340 2060386 (view as bug list)
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-02-14 00:40 UTC by Merlin Cooper
Modified: 2022-05-12 18:52 UTC (History)
16 users (show)

Fixed In Version: sddm-0.19.0^git20220228.c257a40-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-10 07:07:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Merlin Cooper 2022-02-14 00:40:05 UTC
Description of problem:
In Fedora 36 KDE, SDDM has been changed to use a Wayland greeter by default. I noticed some minor cosmetic issues - the background blur looks low quality, the cursor is larger than it should be, and the keyboard layout always defaults to "af" rather than the one I set at installation (Australian English / "au")

More importantly, if you click the desktop session button to change between Plasma's Wayland or X11 session, or the keyboard layout option, the menu spawns in the top-left corner of the screen instead of above the button, and the background rapidly flashes white (like a strobe effect). None of these issues occur if you edit /etc/sddm.conf to change back to the X11 greeter.


Version-Release number of selected component (if applicable):
0.19.0^git20220224.5ad9f19-2.fc36


How reproducible:
Every time, both on real hardware (AMD GPU) and on a virtual machine (VirtualBox)

Steps to Reproduce:
1. Click on any the keyboard layout or desktop session buttons in SDDM on Fedora 36

Actual results:
The menu opens in the top-left corner of the screen and the background rapidly flashes white (strobe effect)

Expected results:
Menu opens above the button like it does in Fedora 35, and no strobe effect.


Additional info:

Comment 1 Timothée Ravier 2022-03-03 17:35:30 UTC
*** Bug 2060340 has been marked as a duplicate of this bug. ***

Comment 2 Timothée Ravier 2022-03-03 17:35:53 UTC
*** Bug 2060386 has been marked as a duplicate of this bug. ***

Comment 3 Timothée Ravier 2022-03-03 17:38:14 UTC
*** Bug 2055627 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Blocker Bugs Application 2022-03-07 01:17:29 UTC
Proposed as a Blocker for 36-beta by Fedora user ngompa using the blocker tracking app because:

 This is serious visual corruption that inhibits the basic functionality (selecting sessions for the login).

Comment 5 Fedora Update System 2022-03-07 01:47:49 UTC
FEDORA-2022-cda6070d01 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-cda6070d01

Comment 6 Fedora Update System 2022-03-07 15:51:21 UTC
FEDORA-2022-cda6070d01 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-cda6070d01`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-cda6070d01

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Geoffrey Marr 2022-03-07 22:24:02 UTC
Discussed during the 2022-03-07 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Beta)", "AcceptedBlocker (Final)", and an "AcceptedFreezeException (Beta)" was made as it doesn't quite seem to violate the Beta criteria, but is bad enough to be worth fixing. 'Default keyboard layout is wrong' portion violates Final criterion: "If a particular keyboard layout has been configured for the system, that keyboard layout must be used: ... When logging in via the default login manager for a release-blocking desktop".

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-07/f36-blocker-review.2022-03-07-17.01.txt

Comment 8 Ben Cotton 2022-03-08 15:17:26 UTC
Adding whiteboard fields so it shows correctly in the Blockerbugs app.

Comment 9 Fedora Update System 2022-03-10 07:07:08 UTC
FEDORA-2022-cda6070d01 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-03-10 07:07:20 UTC
FEDORA-2022-cda6070d01 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Marián Konček 2022-03-10 15:02:56 UTC
Parts of the issue (blinking) were fixed but other remain.
1) Language selection still does not actually change the keyboard layout.
2) After getting the cursor on the password text box, the options below it (like Change user) disappear and it is hard to make them appear again.

Comment 12 Rex Dieter 2022-03-10 16:50:34 UTC
True, part of the problem of reporting multiple issues in a single bug report.

That said, I know at least item 1 is being tracked elsewhere already as a blocker bug

Comment 13 MicMor 2022-05-12 18:52:18 UTC
hello,


I updated fedora 35 (kde) to fedora 36 (kde) with the "dnf system-update" method. 

I have the same problem with sddm. 
- The language of my system is not respected (fr) 
- The numeric keyboard will turn off every time you reboot. 
- And the background rapidly flashes white when I want to change the language (af)

No problem under fedora 35


Version-Release number of selected component (if applicable):
sddm: 0.19.0^git20220321.e67307e
nvidia: kmod-nvidia 510.68.02
*


Note You need to log in before you can comment on or make changes to this bug.