Bug 2054921 - dnf system-upgrade 35 to 36 fails with various pipewire wireplumber conflicts
Summary: dnf system-upgrade 35 to 36 fails with various pipewire wireplumber conflicts
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F36BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-02-16 02:14 UTC by Chris Murphy
Modified: 2023-05-25 19:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-25 19:11:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Chris Murphy 2022-02-16 02:14:35 UTC
$ sudo dnf system-upgrade download --releasever=36
[sudo] password for chris: 
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Copr repo for kgx owned by exalm                                                                                                                                     14 kB/s |  11 kB     00:00    
Copr repo for PyCharm owned by phracek                                                                                                                               50 kB/s |  50 kB     00:01    
Fedora 36 - x86_64                                                                                                                                                  4.7 MB/s |  80 MB     00:16    
Fedora 36 openh264 (From Cisco) - x86_64                                                                                                                            2.7 kB/s | 2.5 kB     00:00    
Fedora Modular 36 - x86_64                                                                                                                                          1.3 MB/s | 2.3 MB     00:01    
Fedora 36 - x86_64 - Updates                                                                                                                                        256  B/s | 257  B     00:01    
Fedora Modular 36 - x86_64 - Updates                                                                                                                                264  B/s | 257  B     00:00    
Fedora 36 - x86_64 - Test Updates                                                                                                                                   306  B/s | 257  B     00:00    
google-chrome                                                                                                                                                        18 kB/s | 3.6 kB     00:00    
RPM Fusion for Fedora 36 - Free                                                                                                                                     778 kB/s | 952 kB     00:01    
RPM Fusion for Fedora 36 - Free - Updates                                                                                                                            50 kB/s | 101 kB     00:02    
Errors during downloading metadata for repository 'rpmfusion-free-updates':
  - Status code: 404 for https://mirrors.rpmfusion.org/metalink?repo=free-fedora-updates-released-36&arch=x86_64 (IP: 2607:5300:201:3100::9322)
Error: Failed to download metadata for repo 'rpmfusion-free-updates': Cannot prepare internal mirrorlist: Status code: 404 for https://mirrors.rpmfusion.org/metalink?repo=free-fedora-updates-released-36&arch=x86_64 (IP: 2607:5300:201:3100::9322)
RPM Fusion for Fedora 36 - Nonfree                                                                                                                                  220 kB/s | 244 kB     00:01    
RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver                                                                                                                   26 kB/s |  14 kB     00:00    
RPM Fusion for Fedora 36 - Nonfree - Steam                                                                                                                          3.6 kB/s | 2.1 kB     00:00    
RPM Fusion for Fedora 36 - Nonfree - Updates                                                                                                                         52 kB/s | 101 kB     00:01    
Errors during downloading metadata for repository 'rpmfusion-nonfree-updates':
  - Status code: 404 for https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-updates-released-36&arch=x86_64 (IP: 2607:5300:201:3100::9322)
Error: Failed to download metadata for repo 'rpmfusion-nonfree-updates': Cannot prepare internal mirrorlist: Status code: 404 for https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-updates-released-36&arch=x86_64 (IP: 2607:5300:201:3100::9322)
TeamViewer - x86_64                                                                                                                                                 1.9 kB/s | 867  B     00:00    
TeamViewer - x86_64                                                                                                                                                  38 kB/s | 3.1 kB     00:00    
Importing GPG key 0x0C1289C0:
 Userid     : "TeamViewer GmbH (TeamViewer Linux 2017) <support>"
 Fingerprint: 8CAE 012E BFAC 38B1 7A93 7CD8 C5E2 2450 0C12 89C0
 From       : https://linux.teamviewer.com/pubkey/currentkey.asc
Is this ok [y/N]: y
TeamViewer - x86_64                                                                                                                                                 825 kB/s | 288 kB     00:00    
Ignoring repositories: rpmfusion-free-updates, rpmfusion-nonfree-updates
no group 'arm-tools' from environment 'workstation-product-environment'
No match for group package "xorg-x11-drv-armsoc"
No match for group package "authselect-compat"
No match for group package "reiserfs-utils"
No match for group package "culmus-shofar-fonts"
No match for group package "polarsys-b612-sans-fonts"
No match for group package "tlomt-junction-fonts"
No match for group package "google-noto-sans-syriac-eastern-fonts"
No match for group package "yanone-tagesschrift-fonts"
No match for group package "google-noto-sans-syriac-estrangela-fonts"
No match for group package "ubuntu-title-fonts"
No match for group package "khmer-os-fasthad-fonts"
No match for group package "drehatlas-warender-bibliothek-fonts"
No match for group package "kanjistrokeorders-fonts"
No match for group package "libguestfs-tools"
No match for group package "drehatlas-xaporho-fonts"
No match for group package "google-noto-sans-tibetan-fonts"
No match for group package "google-noto-sans-syriac-western-fonts"
No match for group package "bcm283x-firmware"
No match for group package "vollkorn-fonts"
Error: 
 Problem: conflicting requests
  - package pipewire-media-session-0.4.1-4.fc36.x86_64 conflicts with pipewire-session-manager provided by wireplumber-0.4.8-1.fc36.i686
  - package wireplumber-0.4.8-1.fc36.i686 conflicts with pipewire-session-manager provided by pipewire-media-session-0.4.1-4.fc36.x86_64
  - package pipewire-media-session-0.4.1-4.fc36.x86_64 conflicts with pipewire-session-manager provided by wireplumber-0.4.8-1.fc36.x86_64
  - package wireplumber-0.4.8-1.fc36.x86_64 conflicts with pipewire-session-manager provided by pipewire-media-session-0.4.1-4.fc36.x86_64
  - problem with installed package pipewire-media-session-0.4.1-3.fc35.x86_64
  - pipewire-media-session-0.4.1-3.fc35.x86_64 does not belong to a distupgrade repository
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)
$ rpm -qa | grep i686

Comment 1 Chris Murphy 2022-02-16 02:27:21 UTC
--allowerasing seems to work around this but I don't think we expect users to figure that out on upgrades do we?

Comment 2 Fedora Blocker Bugs Application 2022-02-16 02:30:43 UTC
Proposed as a Blocker for 36-beta by Fedora user chrismurphy using the blocker tracking app because:

 For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed. 
https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria#Upgrade_requirements

Comment 3 Ben Cotton 2022-02-17 17:48:20 UTC
I can't reproduce this in my test VM (although I do get a plocate conflict). I wouldn't think it matters, but if you disable the third-party repos, does that make a difference?

Comment 4 Chris Murphy 2022-02-18 04:28:54 UTC
No, this conflict remains, but then adds a bunch more (gstreamer, et al).

Comment 5 Adam Williamson 2022-02-18 20:58:13 UTC
What those messages are ultimately saying, I think, is that you currently have pipewire-media-session installed, but the upgrade wants to install wireplumber for some reason. Those two packages conflict, you're meant to have one or the other but not both. The key question here is "why does dnf specifically want to pull in wireplumber when pipewire-media-session is already installed?"

The log messages don't answer that. If you still have the system in the pre-upgrade state, we may need to get more verbose info out of dnf somehow.

I doubt this counts as a criteria validation because I don't think it would affect a clean F34 install (as pipewire-media-session didn't exist in F34 at all) or clean F35 install (F35 defaulted to wireplumber). I think it will only happen if you got pipewire-media-session along the way either by manually picking it, or by upgrading at some time where you wound up with it installed on upgrade (I think there were periods during F35 development where that happened).

Comment 6 Chris Murphy 2022-02-19 06:43:08 UTC
>The log messages don't answer that. If you still have the system in the pre-upgrade state, we may need to get more verbose info out of dnf somehow.

Yep. I have the pre-upgrade state in a btrf snapshot. The embarassing part is the dnf history proves this is not a Fedora 35 clean install.

Best I can tell, it's a clean install of Fedora 34, dnf system-upgrade to 35 on 30 Aug 2021, so after beta freeze, before beta GA. pipewire-media-session-0.3.33-3.fc35.x86_64 was installed during the system upgrade, and wireplumber doesn't appear in the transaction at all. The bug seems decently likely to be a testing artifact.

Comment 7 Adam Williamson 2022-02-23 17:56:37 UTC
Yeah. There was a time during the F35 cycle where, on upgrade from F34, you'd get pipewire-media-session installed, but that wasn't the intention, and by Beta (IIRC) it was fixed so that on upgrade you got wireplumber.

There probably is still a bug that could be resolved or mitigated here, but I think it's clearly not a blocker on current info. We might want to mention it in common bugs, though, as we know some people did manually switch to pipewire-media-session due to issues in wireplumber, and other people will be in your situation (got it during an early F35 cycle upgrade).

The votes in https://pagure.io/fedora-qa/blocker-review/issue/612 are at -5, so rejecting this as a blocker. bcotton voted +1 FE, so marking as a proposed FE.

Comment 8 Geoffrey Marr 2022-02-28 21:07:38 UTC
Discussed during the 2022-02-28 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException (Beta)" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-02-28/f36-blocker-review.2022-02-28-17.00.txt

Comment 9 Ben Cotton 2023-04-25 16:54:08 UTC
This message is a reminder that Fedora Linux 36 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 36 on 2023-05-16.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '36'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 36 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 10 Ludek Smid 2023-05-25 19:11:42 UTC
Fedora Linux 36 entered end-of-life (EOL) status on 2023-05-16.

Fedora Linux 36 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.