Bug 2054953 - Firefox at F36 shipped without habitual fedora project links at favorites panel
Summary: Firefox at F36 shipped without habitual fedora project links at favorites panel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedFreezeException
Depends On:
Blocks: F36FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2022-02-16 05:31 UTC by Geraldo Simião
Modified: 2022-10-05 12:57 UTC (History)
14 users (show)

Fixed In Version: firefox-100.0-1.fc37 firefox-100.0-2.fc36 firefox-105.0.2-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-04 17:33:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
printcreen of firefox, now with bookmarks (401.40 KB, image/png)
2022-03-02 18:58 UTC, Geraldo Simião
no flags Details
new screen shot of firefox after system install (309.50 KB, image/png)
2022-03-02 22:24 UTC, Geraldo Simião
no flags Details
F36 RC1.3 still doesnt have the bookmarks (68.87 KB, image/png)
2022-05-03 22:39 UTC, Geraldo Simião
no flags Details
screenshot firefox 100 (219.21 KB, image/png)
2022-05-04 12:35 UTC, Geraldo Simião
no flags Details
live-session at F36kde RC1.4 (75.98 KB, image/png)
2022-05-04 12:49 UTC, Geraldo Simião
no flags Details
installed F36 KDE rc1.4 (106.75 KB, image/png)
2022-05-04 13:10 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2022-02-16 05:31:09 UTC
Description of problem:
There's no more the habitual fedora favorite links at Firefox (fedora magazine, fedora project, user communities, Red Hat, etc...)


Version-Release number of selected component (if applicable):
firefox-96.0-1.fc36.x86_64 shipped on new f36 branched isos (Fedora-Workstation-Live-x86_64-36-20220215.n.0.iso / Fedora-KDE-Live-x86_64-36-20220215.n.0.iso ) 


How reproducible:
Allways

Steps to Reproduce:
1. Run live session or install new fedora x86_64-36-20220215.n.0.iso
2. Open Firefox
3. look at the favourites bar

Actual results:
only the option to import favourites, and the introduction tab

Expected results:
Allot of Fedora habitual links

Comment 1 Allan Day 2022-02-21 10:21:14 UTC
Presumably this issue is about the predefined Fedora bookmarks? Testing here I don't see any of those bookmarks in F35, but I do see them in F34.

Comment 2 Geraldo Simião 2022-02-21 12:42:15 UTC
(In reply to Allan Day from comment #1)
> Presumably this issue is about the predefined Fedora bookmarks? Testing here
> I don't see any of those bookmarks in F35, but I do see them in F34.

Exactly, there's no more fedora bookmarks at firefox. I didn't noteoced that on F35 because I upgraded directly from F34. But now I'm testing new install of F36 on a VM and there's no bookmarks.

Comment 3 h2d2fyzt 2022-03-01 11:54:08 UTC
Isn't that a Firefox intentional change to reduce fragmentation and standardize the UX across all OSes? Linux Mint doesn't have its custom FF settings anymore too.

Comment 4 Geraldo Simião 2022-03-02 18:58:50 UTC
Created attachment 1863874 [details]
printcreen of firefox, now with bookmarks

It seems with today's ISO (Fedora-Workstation-Live-x86_64-36-20220302.n.0.iso) the habitual links (bookmarks) are back. Great. Will see if its the same at F36KDE.

Comment 5 Geraldo Simião 2022-03-02 22:24:16 UTC
Created attachment 1863908 [details]
new screen shot of firefox after system install

Previous attachment was on a live-session under KVM-qemu. Now, this is with the same iso, after VM installation. Strange that the bookmarks are gone.

Comment 6 Adam Williamson 2022-03-11 22:35:54 UTC
Hmm, now I read carefully, the original report is a bit different from what I see lately.

With firefox-98.0-2.fc36 , it seems like for newly-created profiles, the bookmark toolbar is not displayed *at all*. If you turn it on, you only see the upstream defaults (not Fedora's custom ones).

With firefox-96.0-1.fc36 , a newly-created profile shows the bookmark toolbar and includes all the Fedora defaults. If you then upgrade to firefox 98, the toolbar is still there.

Comment 7 Adam Williamson 2022-03-11 22:57:09 UTC
On that 'visibility' issue...when I boot a live image fresh and run firefox-96.0-1.fc36 , then check `about:config`, the setting `browser.toolbars.bookmarks.visibility` is set to `always` (and shown in bold, indicating this is a change from the default, though I've no idea why or how). If I boot a live image fresh and run firefox-98.0-2.fc36 , the same setting is set to `newtab` (and shown not in bold, indicating this is the default).

Indeed, if I open a new tab with ctrl-t, in this tab the bookmark toolbar is visible. It's just not visible on the home page shown when the app first runs.

However, the bookmark toolbar shown on a new tab does not include all the Fedora predefined bookmarks, just "Import bookmarks..." and "Getting Started".

Comment 8 Adam Williamson 2022-03-11 23:44:41 UTC
Hum, so, I think this change may account for our default bookmarks not working any more:

https://hg.mozilla.org/mozilla-central/rev/da061e3d46331401fd507491155fe4984ded90ad

not sure if it has any relevance to the 'bookmark visibility setting changed' part of the problem. Also not sure what the correct fix is. But that definitely changed where firefox's build process goes looking for default bookmarks, in a way which looks like it would break how we try to get them in there:

# set up our default bookmarks
%if !0%{?flatpak}
%{__cp} -p %{default_bookmarks_file} objdir/dist/bin/browser/chrome/en-US/locale/browser/bookmarks.html
%endif

the change looks a lot like Firefox just won't pay any attention to that file any more. I'm not quite sure what the correct replacement path would be, though, or if we'd be better off replacing browser/base/content/default-bookmarks.html in %prep now instead.

Comment 9 Martin Stransky 2022-03-14 13:42:07 UTC
Thanks for the leg work, will look at it.

Comment 10 Geraldo Simião 2022-03-15 04:38:38 UTC
(In reply to Adam Williamson from comment #6)
> Hmm, now I read carefully, the original report is a bit different from what
> I see lately.
> 
> With firefox-98.0-2.fc36 , it seems like for newly-created profiles, the
> bookmark toolbar is not displayed *at all*. If you turn it on, you only see
> the upstream defaults (not Fedora's custom ones).
> 
> With firefox-96.0-1.fc36 , a newly-created profile shows the bookmark
> toolbar and includes all the Fedora defaults. If you then upgrade to firefox
> 98, the toolbar is still there.

Yeah, I can confirm that here too, with Fedora-KDE-Live-x86_64-36_Beta-1.1.iso

Comment 11 Jan Horak 2022-04-28 11:02:32 UTC
It seems that in Firefox 99 the browser.toolbars.bookmarks.visibility is set to newtab for fresh profole, so the bookmark toolbar is shown only on newly opened tabs, which is probably fine. I'm going to fix the location of the default fedora bookmarks.

Comment 12 Adam Williamson 2022-04-28 23:19:53 UTC
I actually have a very specific reason to like the toolbar being shown on new windows: we use it in openQA to know when Firefox is actually done starting up. The rest of its UI is visible while it's still not really ready for use, so if we just look for that then start trying to use it, things go wrong quite often. Also looking for the bookmark toolbar icon was a helpful way to be sure Firefox was really ready for use before we started interacting with it.

If we're not getting that back, I'll just have to make openQA dumbly wait 10 seconds after seeing the rest of the UI appear, or something :|

Comment 13 Martin Stransky 2022-04-29 14:42:02 UTC
(In reply to Adam Williamson from comment #12)
> I actually have a very specific reason to like the toolbar being shown on
> new windows: we use it in openQA to know when Firefox is actually done
> starting up. The rest of its UI is visible while it's still not really ready
> for use, so if we just look for that then start trying to use it, things go
> wrong quite often. Also looking for the bookmark toolbar icon was a helpful
> way to be sure Firefox was really ready for use before we started
> interacting with it.
> 
> If we're not getting that back, I'll just have to make openQA dumbly wait 10
> seconds after seeing the rest of the UI appear, or something :|

Adam, you can update the preference in firefox profile directly if that helps you.
You can add it to /home/user/.mozilla/firefox/profile_name/user.js file.

Comment 14 Adam Williamson 2022-04-29 17:42:55 UTC
Hmm, that's true. I try to avoid doing 'odd' customizations for openQA tests to try and keep it as close as possible to how things are for real users, but we already have to do various things to Firefox config to stop it showing us popups and surveys all the damn time, so one more tweak probably wouldn't hurt. Thanks for the idea.

Comment 15 Fedora Update System 2022-05-02 19:09:25 UTC
FEDORA-2022-a0e4f5f964 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a0e4f5f964

Comment 16 Fedora Update System 2022-05-02 19:12:11 UTC
FEDORA-2022-a0e4f5f964 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Adam Williamson 2022-05-02 19:24:50 UTC
This was filed against F36, not Rawhide.

Comment 18 Fedora Blocker Bugs Application 2022-05-03 22:36:13 UTC
Proposed as a Freeze Exception for 36-final by Fedora user geraldosimiao using the blocker tracking app because:

 Why lost the habitual customization of default fedora firefox, with all our community and RH links at the predefined bookmarks?

Comment 19 Geraldo Simião 2022-05-03 22:39:24 UTC
Created attachment 1876846 [details]
F36 RC1.3 still doesnt have the bookmarks

Fedora-Workstation-Live-x86_64-36-1.3.iso

Comment 20 Fedora Update System 2022-05-03 23:03:55 UTC
FEDORA-2022-2c4ed935d1 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2c4ed935d1

Comment 21 Geraldo Simião 2022-05-04 12:35:19 UTC
Created attachment 1877017 [details]
screenshot firefox 100

Still without fedora and RH bookmarks at firefox-100.0-2.fc36.x86_64.rpm

Comment 22 Fedora Update System 2022-05-04 12:41:49 UTC
FEDORA-2022-2c4ed935d1 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-2c4ed935d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2c4ed935d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Geraldo Simião 2022-05-04 12:49:21 UTC
Created attachment 1877020 [details]
live-session at F36kde RC1.4

At a live-session of the new RC 1.4 F36 KDE => bookmarks are there.

Comment 24 Geraldo Simião 2022-05-04 13:10:52 UTC
Created attachment 1877021 [details]
installed F36 KDE rc1.4

Good, installed VM of F36 KDE rc1.4 at plasma-wayland session Firefox 100 shows correctly the bookmarks.

Comment 25 Geraldo Simião 2022-05-04 14:11:25 UTC
Bug fixed at Fedora-Workstation-Live-x86_64-36-1.4.iso too. Both live session and installed system. 
Excellent!!

Comment 26 Adam Williamson 2022-05-04 15:29:03 UTC
Geraldo: yeah, you won't see this fixed on an updated system unfortunately because the bookmarks are put in place when a user profile is created. So if your profile was created with one of the broken versions, it won't be fixed on update. (The good side to this is, if your profile was created *before* the broken versions, it wasn't broken on update...)

If you created a new user profile on an updated system, it'd probably look OK. I don't think we can do anything to fix things for folks who first ran Firefox on a broken release besides telling them to create a new profile :(

Comment 27 Adam Williamson 2022-05-04 17:06:52 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/808 , marking accepted FE. Also marking VERIFIED per Geraldo's testing, thanks Geraldo.

Comment 28 Fedora Update System 2022-05-04 17:33:30 UTC
FEDORA-2022-2c4ed935d1 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 29 Fedora Update System 2022-10-05 12:46:15 UTC
FEDORA-2022-f0988ea008 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f0988ea008

Comment 30 Fedora Update System 2022-10-05 12:57:24 UTC
FEDORA-2022-f0988ea008 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.