Bug 20550 - root can crash system using sysreport
Summary: root can crash system using sysreport
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysreport   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-09 00:57 UTC by Victor J. Orlikowski
Modified: 2007-03-27 03:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-09 00:57:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Victor J. Orlikowski 2000-11-09 00:57:16 UTC
Sysreport can be used to crash the system by root users.
It performs a cp -P -R (using catiffile) on /proc/bus,
which causes some PCI devices to hang the machine.

Comment 1 Wil Harris 2000-11-09 16:05:47 UTC
According to Alan "This is known. If you ask lspci to scan all the registers
some cards may lock up and die . Not a bug." 

I have built a work around in sysreport-1.1-2.5 that gets by this issue by doing
an lspci -vn.


Note You need to log in before you can comment on or make changes to this bug.