Bug 2055081 - Update to latest nodejs (14.19.0) is blocked due to dependency issues
Summary: Update to latest nodejs (14.19.0) is blocked due to dependency issues
Keywords:
Status: CLOSED DUPLICATE of bug 2053637
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-16 09:34 UTC by Christian Krause
Modified: 2022-02-16 13:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-16 13:35:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Krause 2022-02-16 09:34:29 UTC
Description of problem:
Can't update to new nodejs due to dependency issues.


Version-Release number of selected component (if applicable):
- installed: 1:14.18.3-1.fc34
- new in repository: 1:14.19.0-2.fc34

How reproducible:
100%


Steps to Reproduce:
1. sudo dnf update

Actual results:
$ sudo dnf update
YYY distribution for Fedora                                                                                                                                                                                   9.6 kB/s | 3.0 kB     00:00    
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package nodejs-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 2: package nodejs-full-i18n-1:14.19.0-2.fc34.x86_64 requires nodejs(x86-64) = 1:14.19.0-2.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-full-i18n-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 3: package npm-1:6.14.16-1.14.19.0.2.fc34.x86_64 requires nodejs = 1:14.19.0-2.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package npm-1:6.14.15-1.14.18.3.1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.i686
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 4: package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.18.3-1.fc34.x86_64
  - problem with installed package nodejs-1:14.18.3-1.fc34.x86_64
  - cannot install the best update candidate for package nodejs-docs-1:14.18.3-1.fc34.noarch
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 5: package nodejs-full-i18n-1:14.18.3-1.fc34.x86_64 requires nodejs(x86-64) = 1:14.18.3-1.fc34, but none of the providers can be installed
  - package nodejs-1:14.18.3-1.fc34.x86_64 requires nodejs-libs(x86-64) = 1:14.18.3-1.fc34, but none of the providers can be installed
  - problem with installed package nodejs-full-i18n-1:14.18.3-1.fc34.x86_64
  - cannot install both nodejs-libs-1:14.19.0-2.fc34.x86_64 and nodejs-libs-1:14.18.3-1.fc34.x86_64
  - package nodejs-full-i18n-1:14.19.0-2.fc34.x86_64 requires nodejs(x86-64) = 1:14.19.0-2.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-libs-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
==============================================================================================================================================================================================================================================
 Package                                                     Architecture                                      Version                                                               Repository                                          Size
==============================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nodejs-docs                                                 noarch                                            1:14.19.0-2.fc34                                                      updates                                            6.2 M
 nodejs-libs                                                 x86_64                                            1:14.19.0-2.fc34                                                      updates                                             13 M
Skipping packages with broken dependencies:
 nodejs                                                      i686                                              1:14.19.0-2.fc34                                                      updates                                            199 k
 nodejs                                                      x86_64                                            1:14.19.0-2.fc34                                                      updates                                            199 k
 nodejs-full-i18n                                            x86_64                                            1:14.19.0-2.fc34                                                      updates                                            8.0 M
 npm                                                         x86_64                                            1:6.14.16-1.14.19.0.2.fc34                                            updates                                            3.3 M

Transaction Summary
==============================================================================================================================================================================================================================================
Skip  6 Packages

Nothing to do.
Complete!


Expected results:
- successful update

Additional info:
It looks like that the real issue is, that nodejs requires now /usr/bin/pwsh which is not provided by any other package.

Comment 1 Stephen Gallagher 2022-02-16 13:35:45 UTC

*** This bug has been marked as a duplicate of bug 2053637 ***


Note You need to log in before you can comment on or make changes to this bug.