Bug 205528 - ssh logs "Postponed public key..." even after applying localtime chroot fix
ssh logs "Postponed public key..." even after applying localtime chroot fix
Status: CLOSED DUPLICATE of bug 203671
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
4.4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 17:24 EDT by Jed Reynolds
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 02:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jed Reynolds 2006-09-06 17:24:09 EDT
Description of problem:

SSH logs "Postponed publickey for root from..." but timezone information present
in chroot. Different problem?


Version-Release number of selected component (if applicable):
RHEL 4.4, openssh-server 3.9.p1, 8.RHEL4.15

How reproducible:
Has occured on a i686 and x86_64. 

Upgraded to 

Steps to Reproduce:
1. Login with public key
2. grep "Postponed" /var/log/secure
3.
  
Actual results:
sshd logs "Postponed publickey for root from...." in /var/log/secure.

Expected results:
No Postponed message.

Additional info:

Similar to #193184, but applied localtime to /var/empty/sshd/etc/localtime. 
Still getting message. 

Strace -s 512 -f on root sshd gives me:
[pid 16309] open("/usr/share/zoneinfo/America/Vancouver", O_RDONLY) = 7
[pid 16309] fstat(7, {st_mode=S_IFREG|0644, st_size=1037, ...}) = 0
[pid 16309] fstat(7, {st_mode=S_IFREG|0644, st_size=1037, ...}) = 0
[pid 16309] mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x2a9557c000
[pid 16309] read(7, "TZif\0\0\0\ 
<SNIP>
 ...25IT \02697\20\27)6 \30\"S"..., 4096) = 1037
[pid 16309] close(7)                    = 0
[pid 16309] munmap(0x2a9557c000, 4096)  = 0
[pid 16309] sendto(6, "<86>Sep  6 13:50:01 sshd[16309]: Postponed publickey for
root from ::ffff:192.168.0.12 port 38488 ssh2", 102, MSG_NOSIGNAL, NULL, 0) = 102
Comment 1 Tomas Mraz 2006-09-07 02:41:14 EDT
The timezone information only changes the timestamp on the new messages, it
doesn't remove any messages from being logged into syslog.


*** This bug has been marked as a duplicate of 203671 ***

Note You need to log in before you can comment on or make changes to this bug.