Bug 205545 - rhn_register must be able to register to RHN backend using the entitlement numbers
rhn_register must be able to register to RHN backend using the entitlement nu...
Status: CLOSED WORKSFORME
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Corey Welton
: FutureFeature
: 207192 (view as bug list)
Depends On: 219655
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 23:33 EDT by Roman Lazarev
Modified: 2007-04-18 13:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 13:14:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Lazarev 2006-09-06 23:33:44 EDT
Description of problem:

RHEL5 as a product introduces "entitlement numbers" to differentiate between the
product variants. This is done to eliminate the multiple installation kits: AS,
ES, WS. The entitlement number will also fulfil the funciton of the
"subscription number" that is currently being used for the RHN registration.
This feature requres a completion by Beta 2 code freeze and is the Beta 2 blocker.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Roman Lazarev 2006-09-19 21:22:57 EDT
This is RHN Backend functionality, required features for the EN registration is
covered by 207194.
Comment 3 Daniel Riek 2007-01-12 11:08:16 EST
THe implementarion of this at this point is purely in hosted RHN and the
backend. rhn_register in RHEL does only send the IN string.

So this is purely a QA item we need to verify before we ship. Should be the last
blocker open.

Comment 4 Bret McMillan 2007-01-18 12:37:10 EST
reassigning to the owner of the soap integration w/ the backend
Comment 6 Bret McMillan 2007-01-18 16:55:32 EST
*** Bug 207192 has been marked as a duplicate of this bug. ***
Comment 7 Fanny Augustin 2007-01-19 13:14:02 EST
This a tracker bug.  No longer needed.

Note You need to log in before you can comment on or make changes to this bug.