Bug 205556 - Drag-and-Drop with Alt doesn't work in icons view
Summary: Drag-and-Drop with Alt doesn't work in icons view
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords: Desktop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-07 06:13 UTC by Xiaohong Wang
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-11 18:00:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (163.06 KB, image/png)
2006-09-07 06:13 UTC, Xiaohong Wang
no flags Details

Description Xiaohong Wang 2006-09-07 06:13:01 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Nautilus-2.15.92.1-2.fc6

How reproducible:
always

Steps to Reproduce:
1. Open Nautilus and select a folder
2. Click the View as drop-down list and choose icon view. 
3. Grab a item in the folder, then press-and-hold Alt
  
Actual results:
Nautilus got move

Expected results:
In List View, A popup menu appears with items Move here, Copy here, Link here... 

Additional info:
Check help information by selecting Help -> Contents
It says "Grab the item, then press-and-hold Alt. You may also use the middle
mouse button to perform the same operation. Drag the item to the location where
you want the item to reside. Release the mouse button. A popup menu appears."

It doesn't point out this only works in List View and doesn't work in Icons View.

Comment 1 Xiaohong Wang 2006-09-07 06:13:02 UTC
Created attachment 135729 [details]
screenshot

Comment 2 Alexander Larsson 2006-09-07 09:03:52 UTC
It works fine for me. 

Also, why did you put in a screenshot of the help?

Comment 3 Alexander Larsson 2006-09-07 09:06:04 UTC
Can you explain in detail what you did and what happened, because this works
very well for me.


Comment 4 Xiaohong Wang 2006-09-07 09:54:34 UTC
In Icons View, if grabbing a folder, press-and-hold Alt, the Nautilus window
would move in the screen, just like press Alt+F7.
But In List View, it works fine, if grabbing a folder, press-and-hold Alt,
release the mouse button. A popup menu appears.

I'm not quite sure whether this by design, if so it should point out in Help
that this only works in List View, but it doesn't. So I put the sreenshot here
for dev to check.

Hope I described clearer than before

thx

Comment 5 Alexander Larsson 2006-09-07 12:18:30 UTC
Let me explain what i mean by "in detail", by describing what happens for me:

A nautilus window is open, showing the icon view with some files in it:
1. point cursor on icon, it highlights
2. press and hold down left mouse button, icon is selected
3. press and hold down the alt key
4. move the mouse a bit, mouse cursor becomes a pointer with a question mark
dragging the icon
5. while over the nautilus window release the mouse button (still holding down
alt), a popup menu with choices appear

This is how it works for me, and how it is supposed to work. At what point is it
behaving differently for you?

If you just say the help says something I believe you. There is no need to fill
the bugzilla database with useless screenshots. Screenshots are useful if you
need to point out a specific rendering issue, but they are rarely needed otherwise.


Comment 6 Xiaohong Wang 2006-10-11 05:17:04 UTC
Re-test in nautilus-2.16.0-4.fc6, steps are

1. open nautilus window with icon view and some files in it
2. point cursor on icon, it highlights, press and then release left button, icon
is selected
3. press and hold down the alt key
4. point cursor on selected icon, press and hold down left mouse button, mouse
cursor becomes a cross cursor
5. move the mouse, then the nautilus window moves


Comment 7 Alexander Larsson 2006-10-11 18:00:15 UTC
holding down alt before you press mouse down will be grabbed by the window
manager to do window moves. This works "as designed".


Note You need to log in before you can comment on or make changes to this bug.