This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 205558 - Two symbols showed abnormally in gedit
Two symbols showed abnormally in gedit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 02:20 EDT by Nicole Dai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 01:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
symbols_input_pad.png (51.87 KB, image/png)
2006-09-07 02:20 EDT, Nicole Dai
no flags Details
gedit and kedit comparison (1.29 MB, image/png)
2006-09-07 02:27 EDT, Nicole Dai
no flags Details

  None (edit)
Description Nicole Dai 2006-09-07 02:20:11 EDT
Description of problem:
There are two symbols showed abnormally in gedit. Compared that, they are showed
normally in kedit. pls refer to attached screenshot for details.

Version-Release number of selected component (if applicable):
gedit-2.15.9-1.fc6
scim-input-pad-0.1.1-5.fc6

How reproducible:
Always

Steps to Reproduce:
1.Launch gedit.
2.Launch Input-pad of SCIM.
3.Select Symbols tab by clicking the forward or back triangle button.
4.Click ♁ and ♂ in gedit.
  
Actual results:
The two symbols are showed as another two symbols.

Expected results:


Additional info:
Comment 1 Nicole Dai 2006-09-07 02:20:11 EDT
Created attachment 135730 [details]
symbols_input_pad.png
Comment 2 Nicole Dai 2006-09-07 02:27:10 EDT
Created attachment 135731 [details]
gedit and kedit comparison
Comment 3 Matthias Clasen 2006-09-07 15:23:46 EDT
Behdad, this looks like a fontconfig issue to me. 

For some odd reason, gucharmap decides to pick female, earth and male
from some CJK fonts, but all the other symbols from dejavu.
Comment 4 Behdad Esfahbod 2006-09-07 15:36:34 EDT
What's the output of:

  fc-match --sort
Comment 5 Nicole Dai 2006-09-07 21:35:10 EDT
[root@dhcp-0-179 ~]# fc-match --sort
DejaVuLGCSans.ttf: "DejaVu LGC Sans" "Book"
DejaVuLGCSans-BoldOblique.ttf: "DejaVu LGC Sans" "Bold Oblique"
l048013t.pfa: "Luxi Sans" "Regular"
n019003l.pfb: "Nimbus Sans L" "Regular"
KacstQura.ttf: "KacstQura" "KacstQura"
lohit_bn.ttf: "Lohit Bengali" "Regular"
lohit_gu.ttf: "Lohit Gujarati" "Regular"
lohit_hi.ttf: "Lohit Hindi" "Regular"
lohit_pa.ttf: "Lohit Punjabi" "Regular"
lohit_ta.ttf: "Lohit Tamil" "Regular"
lohit_ml.ttf: "Lohit Malayalam" "Regular"
lohit_kn.ttf: "Lohit Kannada" "Regular"
lohit_te.ttf: "Lohit Telugu" "Regular"
lohit_or.ttf: "Lohit Oriya" "Regular"
lklug.ttf: "LKLUG" "Regular"
sazanami-gothic.ttf: "Sazanami Gothic" "Gothic-Regular"
uming.ttf: "AR PL ShanHeiSun Uni" "Regular"
gulim.ttf: "Baekmuk Gulim" "Regular"
sazanami-mincho.ttf: "Sazanami Mincho" "Mincho-Regular"
KacstQuran.ttf: "KacstQuran" "KacstQuran"
DavidCLM-Medium.pfa: "David CLM" "Medium"
FrankRuehlCLM-Medium.pfa: "Frank Ruehl CLM" "Medium"
DejaVuLGCSansMono.ttf: "DejaVu LGC Sans Mono" "Book"
DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"
PakTypeNaqsh.ttf: "PakType Naqsh" "Regular"
PakTypeTehreer.ttf: "PakType Tehreer" "Regular"
s050000l.pfb: "Standard Symbols L" "Regular"
cour.pfa: "Courier" "Regular"
ElliniaCLM-Light.pfa: "Ellinia CLM" "Light"
DejaVuLGCSans-ExtraLight.ttf: "DejaVu LGC Sans Light" "ExtraLight"
DejaVuLGCSansMono-Bold.ttf: "DejaVu LGC Sans Mono" "Bold"
KacstQuraFixed.ttf: "KacstQuraFixed" "Regular"
6x12.pcf: "MiscFixed" "SemiCondensed"
6x13.pcf: "MiscFixed" "SemiCondensed"
mplus_f12-euro.pcf.gz: "fxd" "semicondensed"
kaname-latin1.pcf.gz: "Fixed" "Regular"
9x15.pcf: "MiscFixed" "Regular"
console8x16.pcf: "Console" "Regular"
9x18.pcf: "MiscFixed" "Regular"
10x20.pcf: "MiscFixed" "Regular"
Comment 6 Matthias Clasen 2006-09-07 23:33:24 EDT
It appears that this will be (accidentally) fixed in fontconfig 2.3.97
Comment 7 Lawrence Lim 2006-09-07 23:46:29 EDT
Moving to MODIFIED for QE to confirm the fix. Thanks.
Comment 8 Behdad Esfahbod 2006-09-08 11:42:51 EDT
Ah, I'm not surprised that fontconfig 2.3.95 was broken.
Comment 9 Xiaohong Wang 2006-09-29 01:36:00 EDT
Verified that it has been fixed in latest FC6:
# rpm -q fontconfig 
fontconfig-2.4.1-2.fc6

Note You need to log in before you can comment on or make changes to this bug.