Bug 20556 - Notebook does not shut down
Notebook does not shut down
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-08 23:16 EST by agyorgi
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:27:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description agyorgi 2000-11-08 23:16:35 EST
Issuing a "halt" command unmounts all filesystems and shuts down all running daemons as intended... however, 
my notebook does not physically power off after the "power down" message. "shutdown -h now" has the same effect.
Recompiling the stock kernel with Real Mode APM enabled has no effect. Latest kernel (2.2.17) exhibits the same
issue (with and without Real Mode APM support). This behaviour is not exhibited with Windows 98 SE. 
RH Linux 7.0 was freshly installed. The notebook is a Digital HiNote Ultra 2000 system consisting of the following
configuration:

- Pentium 166 MHz CPU w/MMX
- 48 MB of RAM
- 4.3 GB HDD
- CD ROM Drive/3 1/2" FDD
- ESS Integrated sound card

Please let me know if you need any more information from me.
Comment 1 John Gotts 2000-12-01 01:40:14 EST
Did you turn on "Use real mode APM BIOS call to power off"
(CONFIG_APM_REAL_MODE_POWER_OFF)?  On my Sony Vaio PictureBook, the machine
sometimes hung on a halt without the option, but not always.  I recently turned
on the option and perhaps my machine will *always* shut down without crashing,
but who knows?  There may be more than one problem at work.
Comment 2 agyorgi 2000-12-21 23:32:43 EST
jgotts, 

Turning on Real Mode APM BIOS (CONFIG_APM_REAL_MODE_POWER_OFF) in the kernel has no effect. Issue also present
in the virgin kernel 2.2.18.
Comment 3 Alan Cox 2002-12-14 22:27:22 EST
"poweroff" not "Halt"

Note You need to log in before you can comment on or make changes to this bug.