Bug 205562 - maybe shouldn't provide perl(DB)
maybe shouldn't provide perl(DB)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Crypt-SSLeay (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 03:40 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 11:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-09-07 03:40:51 EDT
Description of problem:

I found by chance that perl-Crypt-SSLeay provides perl(DB),
which is also provided by perl. So, at the first sight, 
it seems that there is something wrong. I haven't 
investigated more, so it may be completly right for 
perl-Crypt-SSLeay to provide perl(DB), if it is the case 
sorry for the noise....

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ian Burrell 2006-09-07 16:55:46 EDT
This is caused by the
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/Net/SSL.pm file
containing the line: 

package DB;

This causes the perl provides finder to think it provides "perl(DB)".

It looks like the code is using the Perl debugging API to reach up the stack (a
pretty nasty hack).  I am not sure why it is doing "package DB" instead of
"require DB".

The provides should definitely be filtered out.
Comment 2 Robin Norwood 2006-10-17 15:55:09 EDT
This fix didn't make it into FC6, but should be available as an update, and is
fixed in FC7 and RHEL-5.
Comment 3 Patrice Dumas 2006-10-26 11:31:17 EDT
$ rpm -q --provides perl-Crypt-SSLeay
SSLeay.so  
perl(Crypt::SSLeay) = 0.51
perl(Crypt::SSLeay::CTX)  
perl(Crypt::SSLeay::Conn)  
perl(Crypt::SSLeay::Err)  
perl(Crypt::SSLeay::MainContext)  
perl(Crypt::SSLeay::X509)  
perl(Net::SSL) = 2.77
perl-Crypt-SSLeay = 0.51-11.fc7

Verified, I close the bug with resolution RAWHIDE, feel free
to do otherwise if it is a mistake.

Note You need to log in before you can comment on or make changes to this bug.