Bug 205569 - [ta_IN] Calendar dates completely wrong
Summary: [ta_IN] Calendar dates completely wrong
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-07 11:29 UTC by A S Alam
Modified: 2013-07-03 00:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 16:45:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ta_IN 's date with wrong format (182.32 KB, image/png)
2006-09-07 11:33 UTC, A S Alam
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 355578 None None None Never

Description A S Alam 2006-09-07 11:29:25 UTC
Description of problem:
when you click on Date in system-tray (Gnome Deskto) in Tamil (ta_IN), then date
is shown as text, which should be only numeric.

Version-Release number of selected component (if applicable):
glibc-2.4.90-29

How reproducible:
Everytime during running system-config-time with ta_IN locale

Steps to Reproduce:
1.on gnome-terminal run following command
2. LANG=ta_IN.UTF-8 system-config-time
3. check calender dates
  
Actual results:
Text is appearing instead of Numeric

Expected results:
only Numeric data should be there

Additional info:
1) LANG=ta_IN.UTF-8 cal
output is correct

Comment 1 A S Alam 2006-09-07 11:33:26 UTC
Created attachment 135737 [details]
ta_IN 's date with wrong format

Comment 2 Jens Petersen 2006-09-12 03:18:10 UTC
CC'ing Mayank.

Comment 3 Jens Petersen 2006-09-12 03:22:23 UTC
So the output of "LANG=ta_IN.UTF-8 date" is also wrong?

Comment 4 A S Alam 2006-09-12 04:39:51 UTC
OUTPUT is following:
----------
[aalam@aalam timezones]$ LANG=ta_IN.UTF-8 date
செ செப 12 10:05:58 IST 2006
----------

This is also OK

Comment 5 Jens Petersen 2006-09-12 04:59:32 UTC
Sounds like it may be a translation issue then if it is specific to
scim-config-date.

Comment 6 A S Alam 2006-09-12 07:10:33 UTC
adding Translation to CC and check with him for issue

Comment 7 Jens Petersen 2006-09-12 08:55:38 UTC
Ah, or perhaps it is a GtkCalendar bug?

Comment 8 Matthias Clasen 2006-09-12 13:38:04 UTC
This is a translation error, which I cannot fix since I don't speak that language:

#. Translate to calendar:week_start:0 if you want Sunday to be the
#. * first day of the week to calendar:week_start:1 if you want Monday
#. * to be the first day of the week, and so on.
#.
#: ../gtk/gtkcalendar.c:720
msgid "calendar:week_start:0"
msgstr "$-1¼È¼Þ¼Ó¼í¼µ¼Þ¼¿¼í¼¿¼ß:¼Õ¼Þ¼Ð¼Î¼í_¼Ä¼ê¼¿¼µ¼í¼µ¼Î¼í:0"

This clearly looks as if calendar and week_start have been translated, and
there are many more examples of this in ta.po

I'll file an upstream bug and add a bug ref here.


Comment 9 Jens Petersen 2006-09-12 23:27:47 UTC
ifelix, can you help with this?

Comment 10 Felix 2006-09-13 04:50:49 UTC
mclasen and jens thanks for clearing and I made the necessary modification.I
think it 'll be fixed.


Comment 11 Matthias Clasen 2006-09-13 13:39:48 UTC
Thanks, looking much better now for ta.po. We'll get those updated translations
into FC6 with the next gtk release.

Comment 12 Felix 2006-09-14 04:33:05 UTC
Cool...

Comment 13 Matthias Clasen 2006-09-25 16:45:32 UTC
Fixed in 2.10.4-2


Note You need to log in before you can comment on or make changes to this bug.