Bug 2055879 (CVE-2021-21708) - CVE-2021-21708 php: Use after free due to php_filter_float() failing for ints
Summary: CVE-2021-21708 php: Use after free due to php_filter_float() failing for ints
Keywords:
Status: NEW
Alias: CVE-2021-21708
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2056798 2056799 2056801 2055880 2056800
Blocks: 2055881
TreeView+ depends on / blocked
 
Reported: 2022-02-17 20:43 UTC by Pedro Sampaio
Modified: 2022-04-14 12:41 UTC (History)
6 users (show)

Fixed In Version: php 7.4.28
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in PHP. The vulnerability occurs due to the malformed php_filter_float() function and leads to a use-after-free vulnerability. This flaw allows an attacker to inject a malicious file, leading to a crash or a Segmentation fault.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Pedro Sampaio 2022-02-17 20:43:02 UTC
Use after free due to php_filter_float() failing for ints.

References:

https://bugs.php.net/bug.php?id=81708
https://www.php.net/ChangeLog-7.php

Comment 1 Pedro Sampaio 2022-02-17 20:43:18 UTC
Created php tracking bugs for this issue:

Affects: fedora-all [bug 2055880]

Comment 2 Remi Collet 2022-02-18 06:59:18 UTC
This only affects PHP > 7.4 (where min∕max_range feature was added), older versions are not affectede


Note You need to log in before you can comment on or make changes to this bug.