Bug 205627 - add --enable-exception-hook to apache build
Summary: add --enable-exception-hook to apache build
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-07 17:55 UTC by Christopher McCrory
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 12:39:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher McCrory 2006-09-07 17:55:29 UTC
Description of problem:

(enhancement)

add --enable-exception-hook to configure options

Version-Release number of selected component (if applicable):

httpd-2.2.3-4


How reproducible:

always

Steps to Reproduce:
1. none, part of build process
2.
3.
  
Actual results:
not able to use exception-hook

Expected results:
able to use exception-hook


Additional info:

As far as I can tell, --enable-exception-hook does not cause any performance
slowdowns or other issues and is dis-abled in the httpd.conf by default.

We are currently running into a problem with httpd segfaulting and dumping core.
 ( in RHEL3 ).  We wanted to use mod_whatkilledus (
http://people.apache.org/~trawick/mod_whatkilledus.c ) to help debug the
problem.  whatkilledus requires --enable-exception-hook.  I can see this helping
others in the future with similar problems.

Comment 1 Joe Orton 2006-09-12 14:54:32 UTC
I'm not really convinced about this feature.

Use of mod_log_forensic (which is already shipped in RHEL) is a far safer and
more reliable method to obtain request context from intermittently segfaulting
children, and I'd rather encourage that (or improve it as necessary, if there is
some context which mod_whatkilledus reports which log_forensic misses).


Comment 2 Christopher McCrory 2006-09-12 16:14:50 UTC
For us apache segfaulted once per day or two.  If we had used mod_log_forensic
on our entire web server farm we would have had massive amounts of additional
logs to deal with.  Where mod_whatkilledus would log only the entry we needed.

I'm not advocating adding mod_whatkilledus.c to the RHEL build , just
--enable-exception-hook.  That would allow  mod_whatkilledus or any other module
needing the hook to be easily added later by the local admin.

But I don't have to support it for every RHEL user  :)

either way, thanks.



Comment 3 Joe Orton 2007-04-11 12:39:32 UTC
I do think this feature is flawed in principle, which is really why I don't want
to support it in RHEL, although I appreciate its utility.  When doing post-crash
analysis, to get the most reliable results it's essential to analyse the process
state as close to the point at which it crashed as possible.  This means letting
the process dump core ASAP and analysing that core dump "after the fact".

Attempting to run more code in process after the segfault occurs is inherently
risky because it inevitably *changes* the process state.

As ever - thanks for the request.


Note You need to log in before you can comment on or make changes to this bug.