Bug 205628 - apr-utils needs postgresql
apr-utils needs postgresql
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: apr-util (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 14:02 EDT by Christopher McCrory
Modified: 2008-12-18 07:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 07:51:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2006-09-07 14:02:40 EDT
Description of problem:

apr-util needs postgresql libs

Version-Release number of selected component (if applicable):

apr-util-1.2.7-3

How reproducible:
always

Steps to Reproduce:
1. install apr-util
2.
3.
  
Actual results:
Processing Dependency: libpq.so.4 for package: apr-util

Expected results:
NOT Processing Dependency: libpq.so.4 for package: apr-util


Additional info:

It does not make sense why apr would need postgresql
Comment 1 Bojan Smojver 2007-01-10 18:20:47 EST
Actually, it does make sense. APU includes a PostgreSQL DBD driver, which needs
libraries to work.

This should be closed as not a bug.
Comment 2 Joe Orton 2007-01-10 18:29:20 EST
This does need fixing.  I have a patch to do DBD-drivers-as-DSOs almost ready to
submit upstream.  That will allow splitting out the drivers into subpackages,
and so relaxing the deps chain a bit.

(this isn't likely to happen in the RHEL5 timescale unfortunately)
Comment 3 Bojan Smojver 2007-01-10 19:06:53 EST
Cool.
Comment 4 Christopher McCrory 2007-01-10 20:42:56 EST
(In reply to comment #1)
> Actually, it does make sense. APU includes a PostgreSQL DBD driver, which needs
> libraries to work.
> 

yes, as far as it goes.

I think the bug is that to install apache (httpd) you should not need postgress
anything.


Comment 5 Joe Orton 2007-04-11 08:46:04 EDT
Is the specific concern here the fact that the libs get pulled in at run-time,
or simply the fact that the deps get pulled in at all.

The former is possible to fix - the latter is not really possible to fix in a
RHEL5 update, since it will be a compatibility break (albeit a minor one).  It
is fixed for FC7/future RHEL now.
Comment 6 Bojan Smojver 2008-12-01 18:08:45 EST
Can we close this?
Comment 7 Joe Orton 2008-12-18 07:51:37 EST
So, because we can't fix this in a RHEL5 update, since it would potentially break existing installations, marking as CLOSED->NEXTRELEASE since the fix in Fedora will be picked up in RHEL6.  Thanks for the report, in any case!

Note You need to log in before you can comment on or make changes to this bug.