Bug 205653 - cpqarray module fails to detect arrays
Summary: cpqarray module fails to detect arrays
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chip Coldwell
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 218623 222695
TreeView+ depends on / blocked
 
Reported: 2006-09-07 20:44 UTC by Chip Coldwell
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-23 00:10:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch from scsi-rc-fixes (1.36 KB, patch)
2006-09-07 20:44 UTC, Chip Coldwell
no flags Details | Diff
make the device a PCI bus master; fixes the bug (361 bytes, patch)
2006-10-06 18:31 UTC, Chip Coldwell
no flags Details | Diff
Fix for bug#205653 (640 bytes, patch)
2006-10-10 13:58 UTC, vikas sidana
no flags Details | Diff

Description Chip Coldwell 2006-09-07 20:44:23 UTC
Description of problem:
cpqarray module fails to detect arrays

Version-Release number of selected component (if applicable):
2.6.17-1.2519.4.21.el5

How reproducible:
every time

Steps to Reproduce:
1.  load sym53c8xx module before cpqarray module
 
Actual results:
Disks are not found

Expected results:
Disks should be found

Additional info:
linux-scsi thread here
http://marc.theaimsgroup.com/?l=linux-scsi&m=115591706804045&w=2
upstream kernel patch here
http://www.kernel.org/git/?p=linux/kernel/git/jejb/scsi-rc-fixes-2.6.git;a=commit;h=b2b3c121076961333977f485f0d54c22121df920

Comment 1 Chip Coldwell 2006-09-07 20:44:23 UTC
Created attachment 135808 [details]
upstream patch from scsi-rc-fixes

Comment 3 RHEL Product and Program Management 2006-09-07 21:17:19 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Chip Coldwell 2006-09-08 14:26:01 UTC
(In reply to comment #2)
> Straight-forward fix is upstream. We should include it in 5.0.

Sadly, the straight-forward fix is already in 5.0, and yet the bug persists.

Chip


Comment 5 Tom Coughlan 2006-09-11 20:42:13 UTC

*** This bug has been marked as a duplicate of 205807 ***

Comment 6 Chip Coldwell 2006-09-18 20:57:23 UTC
Hi Mike,

I'm moving our discussion of the cpqarray problem from bug 205807, which really
does seem to be fixed by the upstream patch, to this bug (205653), which is the
one I originally reported.

I've done some more debugging.  I dumped the entire cmdlist_t that is being sent
via sendcmd in cpqarray on both RHEL-4 and RHEL-5.  One thing I noticed is that
one RHEL-4 (which works), the cmdlist->req.sg[0].addr value is block (512 byte)
aligned, but it is not on RHEL-5 (probably due to a color offset in the
underlying slab cache).  Could this be a problem?

Chip


Comment 8 Chip Coldwell 2006-10-04 18:00:14 UTC
# lspci -xxx -s 00:0e.0
00:0e.0 RAID bus controller: LSI Logic / Symbios Logic 53C1510 (rev 01)
00: 00 10 10 00 53 01 10 02 01 00 04 01 08 c0 00 00
10: 01 24 00 00 00 00 00 f6 00 00 00 f5 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 11 0e 40 40
30: 00 00 00 00 40 00 00 00 00 00 00 00 0a 01 1e 08
40: 01 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00
50: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
80: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
90: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
a0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
b0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
c0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
d0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
e0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
f0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

vendor_id: 0x1000 (PCI_VENDOR_ID_NCR or PCI_VENDOR_ID_LSI_LOGIC)
device_id: 0x0010 (PCI_DEVICE_ID_NCR_53C1510)
command:   0x0153 (PCI_COMMAND_SERR | PCI_COMMAND_PARITY |
PCI_COMMAND_INVALIDATE | PCI_COMMAND_MEMORY | PCI_COMMAND_IO)
status:    0x0210 (PCI_STATUS_DEVSEL_MEDIUM | PCI_STATUS_CAP_LIST)
class_revision: 0x01040001 (PCI_CLASS_STORAGE_RAID << 8 | 0x01)

Comment 9 Chip Coldwell 2006-10-04 21:07:04 UTC
The "command" configuration register (0x0153) indicates that the device is not
configured as a bus master.  On the identical system where cpqarray works fine,
the device does come up as a bus master (command == 0x0157).

I wonder if that's significant.


Comment 10 Chip Coldwell 2006-10-06 18:31:24 UTC
Created attachment 137940 [details]
make the device a PCI bus master; fixes the bug

Comment 11 Chip Coldwell 2006-10-09 17:49:22 UTC
Requesting an exception on the grounds of low impact (the change is only to a
very old and rarely used storage controller) and low risk (it's only a one line
patch).

We have a couple of lab machines with this storage controller; it would be nice
if we could run RHEL5 on them.

Chip


Comment 12 Jay Turner 2006-10-09 18:02:56 UTC
QE ack for RHEL5.

Comment 13 vikas sidana 2006-10-10 13:58:32 UTC
Created attachment 138134 [details]
Fix for bug#205653

Comment 14 Don Zickus 2006-10-11 01:36:27 UTC
in kernel-2.6.18-1.2725.el5

Comment 15 Dave Jones 2006-11-24 21:44:02 UTC
if the change from comment #13 is also needed, it should also get pushed
upstream. I don't see it in 2.6.19rc6

(It also doesn't seem to be in RHEL5 CVS from what I can tell)


Comment 16 Chip Coldwell 2006-11-29 16:43:47 UTC
(In reply to comment #15)
> if the change from comment #13 is also needed, it should also get pushed
> upstream. I don't see it in 2.6.19rc6

It's pretty clear that if the one in comment #1 is needed, then the one in
comment #13 must also be needed.  Apparently LSI logic and NCR were using
different PCI device ids for the same device (even though the vendor ids are the
same).

I'll submit to rh-kernel list for RHEL-5.

Chip


Comment 17 RHEL Product and Program Management 2006-12-23 00:10:58 UTC
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.


Comment 18 Chip Coldwell 2007-01-18 16:58:49 UTC
(In reply to comment #15)
> if the change from comment #13 is also needed, it should also get pushed
> upstream. I don't see it in 2.6.19rc6
> 
> (It also doesn't seem to be in RHEL5 CVS from what I can tell)
> 

http://marc.theaimsgroup.com/?l=linux-scsi&m=116483396211563&w=2


Note You need to log in before you can comment on or make changes to this bug.