Bug 20567 - What is wrong - docs or xinetd - trouble with /etc/hosts.allow
Summary: What is wrong - docs or xinetd - trouble with /etc/hosts.allow
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-09 10:01 UTC by Milan Kerslager
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-09 19:24:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2000-11-09 10:01:56 UTC
When I modified /etc/hosts.allow i read the xinetd doc:

With this option (compiling option --with-libwrap) turned on, xinetd will 
first look at your /etc/hosts.{allow|deny} files, then if access is 
granted, it goes through xinetd's internal access control mechanisms.  
Note that xinetd passes the service name, *not* the server name to libwrap

But services in /etc/hosts.allow depend on server name and *not* on 
service name. This is bad as I can't set up different lines for SPOP and 
IMAPS.

Comment 1 Tim Waugh 2000-11-09 12:53:04 UTC
This is a documentation problem.  The server name is used, since that's what's
always been used in those files.

Comment 2 Trond Eivind Glomsrxd 2000-11-09 19:24:29 UTC
The behaviour in xinetd was changed to match the old behaviour, but the
documentation wasn't changed... will fix.

Comment 3 Trond Eivind Glomsrxd 2000-11-09 19:51:18 UTC
Fixed in xinetd-2.1.8.9pre12-3, which eventually will show up in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.