Bug 205708 - traceback message occurs after every package upgrade
traceback message occurs after every package upgrade
Status: CLOSED DUPLICATE of bug 202091
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
: Desktop
Depends On:
  Show dependency treegraph
Reported: 2006-09-07 22:47 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-13 14:23:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-09-07 22:47:09 EDT
Description of problem:
Noticed the following traceback after a package upgrade

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.upgrade a package using yum

Actual results:
package upgrade properly, some traceback observed

Expected results:
no traceback

Additional info:

# yum upgrade pirut
Deprecated constant TYPE_INTERFACE during plugin initialization.
Please use TYPE_INTERACTIVE instead.
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for pirut to pack into transaction set.
pirut-1.1.12-1.noarch.rpm 100% |=========================|  20 kB    00:00
---> Package pirut.noarch 0:1.1.12-1 set to be updated
--> Running transaction check

Dependencies Resolved

 Package                 Arch       Version          Repository        Size
 pirut                   noarch     1.1.12-1         development       191 k

Transaction Summary
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 191 k
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : pirut                        ######################### [1/2]
  Cleanup   : pirut                        ######################### [2/2]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
  File "/usr/share/yum-cli/yummain.py", line 180, in main
  File "/usr/share/yum-cli/cli.py", line 683, in doTransaction
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 440, in
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 152, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 70, in posttrans_hook
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 77, in
    up2dateAuth.getSystemId(), pkgs)  File
"/usr/share/rhn/up2date_client/rpcServer.py", line 235, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 45, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 325, in _request
    request = self._req_body(params, methodname)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 232, in _req_body
    return xmlrpclib.dumps(params, methodname, encoding=self._encoding)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1029, in dumps
    data = m.dumps(params)
  File "/usr/lib/python2.4/xmlrpclib.py", line 603, in dumps
    dump(v, write)
  File "/usr/lib/python2.4/xmlrpclib.py", line 615, in __dump
    f(self, value, write)
  File "/usr/lib/python2.4/xmlrpclib.py", line 619, in dump_nil
    raise TypeError, "cannot marshal None unless allow_none is enabled"
TypeError: cannot marshal None unless allow_none is enabled
Comment 1 Jeremy Katz 2006-09-11 15:38:32 EDT
That's coming from the yum-rhn-plugin
Comment 2 James Bowes 2006-09-13 14:23:05 EDT

*** This bug has been marked as a duplicate of 202091 ***

Note You need to log in before you can comment on or make changes to this bug.