Bug 2057193 - f36 composes still have firefox 96, f34 f35 have firefox 97
Summary: f36 composes still have firefox 96, f34 f35 have firefox 97
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On: 2056443 2060755
Blocks: F36BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2022-02-22 22:33 UTC by Chris Murphy
Modified: 2022-03-17 18:37 UTC (History)
17 users (show)

Fixed In Version: firefox-98.0-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-17 18:37:28 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Chris Murphy 2022-02-22 22:33:48 UTC
Fedora 34 and 35, have Firefox 97 in stable updates. And Fedora 36 still doesn't have a successful build of Firefox 97.

It seems suboptimal, possibly not even supported, for Firefox to get a downgrade from 97 to 96 during an f34/35->f36 upgrade.

Comment 1 Fedora Blocker Bugs Application 2022-02-22 22:35:21 UTC
Proposed as a Freeze Exception for 36-beta by Fedora user chrismurphy using the blocker tracking app because:

 I'm pretty sure we need to do a freeze exception here, but I'm not sure what the plan is, so I'm kinda winging it.

If firefox (profiles) can't reliably tolerate being downgraded, this could plausibly be a blocker.

Comment 2 Chris Murphy 2022-02-22 22:42:08 UTC
Firefox is a critical path app
https://pagure.io/fedora-comps/blob/main/f/comps-f36.xml.in#_664

Firefox 97 update states it provides urgent security updates
https://bodhi.fedoraproject.org/updates/FEDORA-2022-f044a6dede

And beta release criterion says:
A bug is considered a Beta blocker bug if any of the following criteria are met:
    A bug in a Critical Path package that:
        Cannot be fixed with a future stable update
        Has a severity rating of high or greater and no reasonable workaround (see definition of severity and priority)
    Bug hinders execution of required Beta test plans or dramatically reduces test coverage

So I'm gonna go with, this is a blocker. We need to ship Firefox 97.

Comment 3 Chris Murphy 2022-02-23 01:32:30 UTC
whoops

Comment 4 Martin Stransky 2022-02-23 15:00:39 UTC
Depends on Bug 2056443 (GCC 12 internal error while Firefox build).

Comment 5 Chris Murphy 2022-02-25 00:41:33 UTC
I didn't know at the time I filed this bug, but I've since reproduced significant rendering and/or usability problems with some sites when doing Firefox 96->Firefox 97->Firefox 96, i.e. an upgrade followed by a downgrade. In order to restore functionality in Firefox 96 for those sites, I had to blow away the user profile. It wasn't enough to clean the cache. 
https://bugzilla.mozilla.org/show_bug.cgi?id=1756517

Comment 6 Martin Stransky 2022-02-25 06:46:07 UTC
(In reply to Chris Murphy from comment #5)
> I didn't know at the time I filed this bug, but I've since reproduced
> significant rendering and/or usability problems with some sites when doing
> Firefox 96->Firefox 97->Firefox 96, i.e. an upgrade followed by a downgrade.
> In order to restore functionality in Firefox 96 for those sites, I had to
> blow away the user profile. It wasn't enough to clean the cache. 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1756517

Yes, that's expected - don't do the downgrade.

Comment 7 Geoffrey Marr 2022-02-28 20:58:29 UTC
Discussed during the 2022-02-28 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Beta)" was made as it violates the following Basic and Beta criteria:

"The web browser must be able to download files, load extensions (if applicable), and log into FAS"
"All known bugs that can cause corruption of user data must be fixed or documented at Common F36 bugs"

We also cite the Beta blocker catch-all wording, that "A bug is considered a Beta blocker bug if ... Bug hinders execution of required Beta test plans or dramatically reduces test coverage" - we believe this bug would have that effect, as it would prevent people who would otherwise upgrade to the Beta and help test from doing so.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-02-28/f36-blocker-review.2022-02-28-17.00.txt

Comment 8 Geraldo Simião 2022-03-01 02:42:07 UTC
Does this update here solve the problem? https://bodhi.fedoraproject.org/updates/FEDORA-2022-e056239611
When new build Wil be tried?

Comment 9 Adam Williamson 2022-03-01 16:28:31 UTC
It looks like it should, yeah. The Rawhide build of 98 didn't succeed, but it got through the actual compilation stage and failed later. I'll get that update pushed stable soon.

Comment 10 Adam Williamson 2022-03-03 16:29:33 UTC
Oh, no, now I look more carefully, compile is still failing on f36/f37 :( It seems like https://bugzilla.redhat.com/show_bug.cgi?id=2056443#c6 is still the problem in the latest attempt. Martin, is there any update here? This is blocking F36 Beta. Thanks!

Comment 11 Martin Stransky 2022-03-03 19:32:33 UTC
(In reply to Adam Williamson from comment #10)
> Oh, no, now I look more carefully, compile is still failing on f36/f37 :( It
> seems like https://bugzilla.redhat.com/show_bug.cgi?id=2056443#c6 is still
> the problem in the latest attempt. Martin, is there any update here? This is
> blocking F36 Beta. Thanks!

Yes, I'm working on that.

Comment 12 Adam Williamson 2022-03-04 22:22:43 UTC
Doesn't need to be both a blocker and an FE.

Comment 13 Jakub Jelinek 2022-03-10 15:04:21 UTC
Fixed gcc is already in rawhide, for f36 feel free to build against f36-build-side-51805 which has the fixed gcc.

Comment 14 Adam Williamson 2022-03-10 16:23:30 UTC
I started a build.

Comment 15 Fedora Update System 2022-03-10 23:55:47 UTC
FEDORA-2022-42ea499a7d has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-42ea499a7d

Comment 16 Fedora Update System 2022-03-11 19:25:17 UTC
FEDORA-2022-42ea499a7d has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-42ea499a7d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-42ea499a7d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Lukas Ruzicka 2022-03-14 10:21:37 UTC
My current Firefox version on F36 preBeta is 98 and it works ok.

Comment 18 Geraldo Simião 2022-03-15 05:18:59 UTC
Fedora-KDE-Live-x86_64-36_Beta-1.1.iso have firefox-98.0-2.fc36 working fine so far

Comment 19 Adam Williamson 2022-03-15 05:50:48 UTC
Unfortunately it's broken on aarch64, which is why I didn't include it in the push request yet. Hoping we can get that fixed quickly.

Comment 20 Fedora Update System 2022-03-17 17:10:16 UTC
FEDORA-2022-42ea499a7d has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-42ea499a7d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-42ea499a7d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2022-03-17 18:37:28 UTC
FEDORA-2022-42ea499a7d has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.