Bug 2057208 - [CAPI] Unable to create ACI due to missing spec.imageSetRef (RHACM bundled with Assisted)
Summary: [CAPI] Unable to create ACI due to missing spec.imageSetRef (RHACM bundled w...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Advanced Cluster Management for Kubernetes
Classification: Red Hat
Component: Infrastructure Operator
Version: rhacm-2.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Michael Filanov
QA Contact: Chad Crum
Derek
URL:
Whiteboard:
Depends On: 2056669
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-22 23:12 UTC by Chad Crum
Modified: 2022-10-03 20:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-10-03 20:20:49 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github stolostron backlog issues 20138 0 None None None 2022-02-23 01:23:02 UTC
Red Hat Issue Tracker MGMTBUGSM-111 0 None None None 2022-02-22 23:20:51 UTC

Description Chad Crum 2022-02-22 23:12:54 UTC
Description of the problem:
Unable to deploy Hypershift hosted cluster with agent capi provider (Using Assisted bundled with RHACM 2.5) because ACI creation is rejecting with:

failed to create AgentClusterInstall" func="github.com/openshift/cluster-api-provider-agent/controllers.(*AgentClusterReconciler).ensureAgentClusterInstall" file="/workspace/controllers/agentcluster_controller.go:277" agent_cluster=chub1-0 agent_cluster_namespace=clusters-chub1-0 error="AgentClusterInstall.extensions.hive.openshift.io \"chub1-0\" is invalid: spec.imageSetRef: 

Release version:
ACM DS Snapshot 2.5.0-DOWNSTREAM-2022-02-22-05-50-36
OCP version 4.10.0-0.nightly-2022-02-22-093600

Steps to reproduce:
1. Deploy OCP 4.10 IPI BM in ipv4 env
2. Deploy ACM 2.5 with Assisted + Hive bundled operators
3. Deploy Hypershift
4. Create a hypershift hosted cluster using agent capi provider

Actual results:
ACI does not get created due to:

time="2022-02-22T22:58:07Z" level=error msg="failed to create AgentClusterInstall" func="github.com/openshift/cluster-api-provider-agent/controllers.(*AgentClusterReconciler).ensureAgentClusterInstall" file="/workspace/controllers/agentcluster_controller.go:277" agent_cluster=chub1-0 agent_cluster_namespace=clusters-chub1-0 error="AgentClusterInstall.extensions.hive.openshift.io \"chub1-0\" is invalid: spec.imageSetRef: Required value"
2022-02-22T22:58:07.680Z        ERROR   controller.agentcluster Reconciler error        {"reconciler group": "capi-provider.agent-install.openshift.io", "reconciler kind": "AgentCluster", "name": "chub1-0", "namespace": "clusters-chub1-0", "error": "AgentClusterInstall.extensions.hive.openshift.io \"chub1-0\" is invalid: spec.imageSetRef: Required value"}



Expected results:
ACI is created successfully 

Additional info:

Comment 1 Chad Crum 2022-02-23 14:13:25 UTC
This is specifically related to ACM bug https://bugzilla.redhat.com/show_bug.cgi?id=2056669: ACM is not giving the latest CRDs for infrastructure operator.

Per Michael Filanov: "
will be resolved with https://github.com/stolostron/hub-crds/pull/101 
As a workaround it's possible to apply a newer version of the CRD https://github.com/openshift/assisted-service/blob/release-ocm-2.4/deploy/olm-catalog/manifests/extensions.hive.openshift.io_agentclusterinstalls.yaml
The code already knows how to handle this configuration the problem is in the release that have older version of the CRD.
"

Once ACM is giving the latest CRDs, we can validate this works and close.

Comment 2 Chad Crum 2022-03-08 12:37:51 UTC
I verified this was fixed with DS snapshot 2.5.0-DOWNSTREAM-2022-03-07-12-45-01.

CAPI agent deployed properly as it had correct crds.


Note You need to log in before you can comment on or make changes to this bug.