This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 205721 - fmio uses direct port IO when it shouldn't
fmio uses direct port IO when it shouldn't
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fmio (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Shevchenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc
  Show dependency treegraph
 
Reported: 2006-09-08 04:17 EDT by Andy Shevchenko
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.8-10.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 00:35:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2006-09-08 04:17:12 EDT
Description of problem:
The PPC build is broken due to some source isn't correct for PPC headers.

...
make[1]: Entering directory `/builddir/build/BUILD/fmio-2.0.8/src'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make 
rule.
cc -DSYSCONFDIR=\"/etc\" -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -
fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -fPIC -DNOMIXER -I/
builddir/build/BUILD/fmio-2.0.8/src -o access.o -c access.c
In file included from access.c:38:
radio_drv.h:35:20: error: sys/io.h: No such file or directory
access.c: In function 'os_iopl':
access.c:87: warning: implicit declaration of function 'iopl'
access.c: In function 'os_ioperms':
access.c:96: warning: implicit declaration of function 'ioperm'
make[1]: *** [access.o] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/fmio-2.0.8/src'
...

Version-Release number of selected component (if applicable):
2.0.8-7
Comment 1 Andy Shevchenko 2006-09-08 06:19:50 EDT
So, temporary stop build for non-x86 arches.
Comment 2 Kevin Fenzi 2006-09-08 11:46:48 EDT
You should probibly add:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179260
as a blocker here.
Comment 3 Andy Shevchenko 2006-09-09 04:07:29 EDT
Sure. Thanks.
Comment 4 David Woodhouse 2006-09-09 04:25:34 EDT
What is this code trying to do? You can't have port I/O address from userspace
directly on most architectures, but this code is trying to do that.

If the package contains generic code which works properly through kernel device
drivers (which is what it _should_ be doing anyway), then you should build that
part on PowerPC, and just disable building the direct-io hacks. 
Comment 5 Andy Shevchenko 2006-09-09 04:35:20 EDT
This code has included the set of FM card drivers as libradio. The main 
author's idea was to get working FM card independend of kernel driver.
However, the driver set is included the v4l module for generic kernel device.
Comment 6 Andy Shevchenko 2006-09-11 04:31:00 EDT
Cite from mainstream:

Date:	Sun, 10 Sep 2006 11:11:15 +0400 (MSD)
From: "Vladimir Popov" <jumbo@narod.ru>
Message-Id: <4503BA93.000008.13099@pantene.yandex.ru>
To: andy@smile.org.ua
Subject: Re: fmio vs. contribution and licensing

>The pam mechaism of the Fedora and clones provides the special 
>attributes for devices to console owner. Hence, /dev/radio for me (login 
>name: andy) has permissions like:
>   600 andy:root
>And user andy can operate with /dev/radio w/o root perms obviously.

You're talking about v4l. The driver was included only for a convenience.
See below.

>So, a new information I'd like to discuss. Since FE is built on i686, 
>x86_64, and ppc arches the last case isn't compatible with fmio sources.
>Additional information can be retrived by following url:
>https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205721
>
>What could you advise here?

fmio was developed to operate fm cards when kernel doesn't have an
appropriate driver (I'm speaking about all frunixes). In the time I've
been writing it such situation was commonplace and the only hardware
available for me was i386. This explains why fmio uses direct port
access and is compatible only with i386 (and why it should keep the
setuid bit).

Thus, unless you're going to add support for other arches, you should
build fmio only for i686.
Comment 7 David Woodhouse 2006-12-28 10:26:03 EST
(In reply to comment #6)
> Thus, unless you're going to add support for other arches, you should
> build fmio only for i686.

No, we should build it with only the driver for v4l and not the direct port I/O.
That shouldn't be hard. The X front end is still perfectly useful on other
architectures.

Comment 8 Fedora Update System 2007-11-12 18:58:26 EST
fmio-2.0.8-10.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fmio'
Comment 9 Fedora Update System 2007-11-12 19:07:18 EST
fmio-2.0.8-10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fmio'
Comment 10 Fedora Update System 2007-11-17 00:35:16 EST
fmio-2.0.8-10.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2007-11-17 00:36:20 EST
fmio-2.0.8-10.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.