Bug 2057563 - The About button sends Discover into loop and the application stops responding.
Summary: The About button sends Discover into loop and the application stops responding.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-kirigami2
Version: 36
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-02-23 15:42 UTC by Lukas Ruzicka
Modified: 2022-04-14 23:23 UTC (History)
8 users (show)

Fixed In Version: kf5-kirigami2-5.91.0-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-14 23:23:26 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Logs from the affected machine. (2.88 MB, text/plain)
2022-02-23 15:42 UTC, Lukas Ruzicka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 448784 0 HI CONFIRMED ScrollBar binding loop can cause apps to freeze 2022-03-31 20:32:42 UTC

Description Lukas Ruzicka 2022-02-23 15:42:52 UTC
Created attachment 1863021 [details]
Logs from the affected machine.

Description of problem:

When the About button is clicked on in Discover, the application stops responding and must be killed. In logs, lines can be found, that the application enters some kind of loop.

Version-Release number of selected component (if applicable):
discover 5.24.1

How reproducible:
Always

Steps to Reproduce:
1. Start Discover.
2. Click the About button in the left lower corner.

Actual results:

Applications stops responding.

Expected results:

Application should stay responsive.

Additional info:

See the attached logs, especially

Feb 23 15:29:12 fedora plasma-discover[21289]: file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:148:5: QML FormLayout: Binding loop detected for property "implicitHeight"
Feb 23 15:29:12 fedora plasma-discover[21289]: Qt Quick Layouts: Polish loop detected. Aborting after two iterations.
Feb 23 15:29:12 fedora plasma-discover[21289]: file:///usr/lib64/qt5/qml/org/kde/kirigami.2/AboutItem.qml:148:5: QML FormLayout: Binding loop detected for property "implicitHeight"

Comment 1 Fedora Blocker Bugs Application 2022-02-23 15:44:08 UTC
Proposed as a Blocker for 36-final by Fedora user lruzicka using the blocker tracking app because:

 I am proposing this as a blocker because it hinders the "Basic Functionality" of the application.

Comment 2 Geoffrey Marr 2022-02-28 21:12:48 UTC
Discussed during the 2022-02-28 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Final)" was made as it violates the default application functionality criterion, which requires that the KDE package manager (that's Discover) "must start successfully and withstand a basic functionality test".

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-02-28/f36-blocker-review.2022-02-28-17.00.txt

Comment 3 Geraldo Simião 2022-03-03 00:42:32 UTC
Bug confirmed on Fedora-KDE-Live-x86_64-36-20220302.n.0.iso

Comment 4 Geraldo Simião 2022-03-15 05:22:40 UTC
Didn't see it anymore at Fedora-KDE-Live-x86_64-36_Beta-1.1.iso I think its fixed alright.

Comment 5 Ben Cotton 2022-03-25 19:19:47 UTC
I see it on installed Beta-1.1 with all updates applied as well as a live session of Beta-1.4. I'm not sure why Geraldo didn't see it, but it appears to still be an issue.

Comment 6 Ben Cotton 2022-03-25 19:23:44 UTC
There's an existing upstream report: https://bugs.kde.org/show_bug.cgi?id=447958

Comment 7 Geraldo Simião 2022-03-30 04:51:00 UTC
I tested again now, with a fresh beta 1.4 iso VM install and found that it occurs on plasma-wayland, but not x11.

Comment 8 Ben Cotton 2022-03-31 20:32:43 UTC
Upstream marked their bug as a duplicate, so linking the new one (https://bugs.kde.org/show_bug.cgi?id=448784)

Comment 10 František Zatloukal 2022-04-09 17:03:36 UTC
(In reply to Ben Cotton from comment #9)
> Upstream has a commit with a candidate fix:
> https://invent.kde.org/frameworks/kirigami/commit/
> 57187b7e6a1c6396c95b9450ff4c8acb8e70f431
> 
> https://bugs.kde.org/show_bug.cgi?id=447958

That commit fixes the issue, I've pinged Rex regarding the form of backport. Here is a scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=85403150

Comment 11 Fedora Update System 2022-04-11 08:55:04 UTC
FEDORA-2022-206d187b31 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-206d187b31

Comment 12 Fedora Update System 2022-04-11 08:57:47 UTC
FEDORA-2022-206d187b31 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 František Zatloukal 2022-04-11 09:33:12 UTC
We need it fixed for F36...

Comment 14 Fedora Update System 2022-04-11 15:35:53 UTC
FEDORA-2022-120719a555 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-120719a555

Comment 15 Fedora Update System 2022-04-12 14:45:41 UTC
FEDORA-2022-120719a555 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-120719a555`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-120719a555

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Lukas Ruzicka 2022-04-13 07:38:38 UTC
The latest update of the kf5-kirigami2 (kf5-kirigami2-5.91.0-3.fc36.x86_64) works normally.

Comment 17 sumantro 2022-04-13 20:33:08 UTC
The update fixes the problem. During the live boot however, when I click, the Gotostore button or email button.. nothing happens. 
After installing, the problem is fixed magically. :\

Comment 18 Fedora Update System 2022-04-14 23:23:26 UTC
FEDORA-2022-120719a555 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.